Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Определить количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу N

5-9 класс

Иринка123455 10 июня 2013 г., 0:18:07 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elenasekisova
10 июня 2013 г., 2:21:24 (10 лет назад)

var N,i,k,L:integer;
begin
read (N);
L:=0;
for i:=100 to 999 do
begin
k:=((i mod 100) mod 10) + ((i mod 100) div 10) + (i div 100);
if (k=N) then
begin
L:=L+1;
end;
end;
writeln (L);
end.

Ответить

Другие вопросы из категории

Племя Мульти пишет письма, пользуясь 17-символьным алфавитом. Племя Пульти пользуется 32-символьным алфавитом. Вожди племен обменялись письмами. Письмо

племени Мульти содержало 100 символов, а письмо племени Пульти - 50 символов. Сравните объемы информации, содержащиеся в письмах.

Помогите

.Три друга – Алеша, Сережа и Денис – купили щенков разной породы – колли, ротвейлер и овчарку. Дали им клички – Джек, Гриф и Шарик. Известно, что:- Щенок Алеши темнее по окрасу, чем овчарка, Шарик и Джек;- Щенок Сережи старше Джека, ротвейлера и овчарки.

Читайте также

1. Производительность формовочной машины - 7 тарелок в минуту. Сколько тарелок произведут N машин за T часов?

2. Составить программу удвоения большего из двух чисел.

3. Написать программу вычисления произведения всех двузначных четных чисел.

4. Определить количество двузначных натуральных чисел, сумма цифр которых равна заданному числу N.

Все в Pascal. Очень прошу помочь

1)В диапазоне от 0 до 100 подсчитать количество чисел оканчивающихся на 3.

2)В диапазоне от 0 до 50 подсчитать количество чисел сумма цифр которых равна 3.

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Выведите

на печать все числа, меньшие 10000,
сумма цифр которых равна некоторому числу, вводимому с клавиатуры



Вы находитесь на странице вопроса "Определить количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу N", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.