Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Pascal! Срочно!!!!!!

5-9 класс

Дан массив. Найти ср. арифм. всех четных элементов массива (в массив могут входит пол. и отр. числа)

Huyganeji21 25 марта 2017 г., 4:59:11 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Qweyyfjyf
25 марта 2017 г., 5:34:27 (7 лет назад)

const n=4;
var a:array[1..n] of integer;
j,s,k:integer;
sr:real;
begin
for j:=1 to n do a[j]:=random(50)-20;
for j:=1 to n do write(a[j]:4);
sr:=0; s:=0;
for j:=1 to n do
if (a[j] mod 2 = 0) then begin
s:=s+a[j]; k:=k+1;
 end;
sr:=s/k;
writeln;
write('среднее арифметическое всех четных элементов массива = ',sr);
end.

Ответить

Другие вопросы из категории

СРОЧНО!Напишите задачу в паскаль.

1.дано натуральное число определить сумму кубов его цифр
2. дано натуральное число определить его первую цифру

1.заполните одномерный массив B1 размерностью в N(< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным

номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов в массиве. сформированный массив вывести на экран в столбик.
2.а) найдите среднюю температуру за неделю. (температура была: -5; -3; -7; -6; -2; -4; -3)
б) сколько дней было выше средней? ниже средней?
3. сформируйте массив BC размерностью 30 элементов случайным образом из диапазона 0 - 50. сформированный массив выведите на экран в строку. подсчитайте сумму всех четных элементов массива и отдельно сумму элементов имеющих четные индексы. выведите результаты подсчета на экран. замените элементы равные своему индексу на самый большой элемент массива, если таковые имеются. получившийся массив выведите на экран в столбик. отсортируйте получившейся массив по убыванию.

Читайте также

Очень срочно. даю 100 пунктов. Pascal ABC. Если не сдам, будет 3 за четверть(((((((((((((( Написать программу, которая

сортирует массив ПО УБЫВАНИЮ и ищет в нем элемент, равный X (это число вводится с клавиатуры). Использовать двоичный поиск.

Срочно нужна сказка об информатике и

человеке! Буду благодарна! 6 класс Уже 4 раз пишу:с На завтра срочно нужно,не знаю что писать :ссс

Срочно! Напишите сообщение про Системный блок. Рзамером, примерно с альбомный лист.

Только содердательно и понятным языком. Срочно, пожалуйста помогите!

:)

Помогите пожалуйста, срочно надо Составь программу на Pascal для этой задачи:

С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. Какое наименьшее количество коробок потребуется для перевозки N килограмм конфет?



Вы находитесь на странице вопроса "Pascal! Срочно!!!!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.