Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Помогите пожалуйста, срочно надо Составь программу на Pascal для этой задачи:

5-9 класс

С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. Какое наименьшее количество коробок потребуется для перевозки N килограмм конфет?

Peac0ck 27 июня 2013 г., 18:24:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AsyXD
27 июня 2013 г., 19:19:14 (10 лет назад)

program lala;

var a,b,c,n,v:integer;

begin

writeln('vvedite chislo konfet');

readln(n);

a:=(n div 10);

b:=n-(a*10);

if b>5 then

c:=b-5;

b:=1;

v:=a+b+c;

writeln('naimensee chislo coroboc ravno',v);

else

v:=a+b;

writeln('naimensee chislo coroboc ravno',v);

end.

+ 0 -
XxxDevilkeksxxx
27 июня 2013 г., 21:23:46 (10 лет назад)

var a,b,c,i:integer;
m:real;

begin
a:=10;
b:=5;
c:=1;
writeln ('Введите массу конфет (кг)');
readln (i);

if (i mod 10) =0 then m:=i div a;
if (i mod 10) =5 then m:=(i div a)+1;
if (i mod 10 =1) or (i mod 10 =2) or (i mod 10 =3) or (i mod 10 =4) then m:=(i div a)+c*(i mod 10);
if (i mod 10=6) or (i mod 10=7) or (i mod 10=8) or (i mod 10=9) then m:=(i div a)+1+c*(i mod 5);

writeln (m);
end.

Ответить

Другие вопросы из категории

Читайте также

Ребят, помогите пожалуйста, срочно надо)))!!!!!

Составить программу для паскаля.
1) y=x^8
2) y=x^10

СОСТАВИТЬ ПРОГРАММУ НА ПАСКАЛЕ.

Агент 007 узнал, что в секретном сейфе трёхзначный код, в котором все три цифры разные.При этом средняя цифра равна разности крайних цифр. Составить программу, которая напечатает для него все такие числа.



Вы находитесь на странице вопроса "Помогите пожалуйста, срочно надо Составь программу на Pascal для этой задачи:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.