Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

20-04-2014 11:01:55

10-11 класс

3 уровень 15. Заданы координаты (на плоскости) вершин четырехугольника. Определить, является ли он: а) ромбом;

Arishylya 22 июля 2013 г., 9:46:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Icorr
22 июля 2013 г., 10:21:51 (10 лет назад)

var
  x,y,s:real;
  i,f:integer;
begin
f:=1;
for i:=1 to 4 do
  begin
  write('Введите координаты точки: ');
  readln(x,y);
  if i=1 then
    s:=sqrt(x*x+y*y)
    else if s<>sqrt(x*x+y*y) then f:=0;
  end;
if f=1 then
   writeln('Да, является ромбом')
   else writeln('Нет, не является ромбом');
end.

+ 0 -
Анютка2312
22 июля 2013 г., 11:59:19 (10 лет назад)

Программа в паскале

Ответить

Другие вопросы из категории

Паскаль

Задан целочисленный массив A[n]. Определить, сколько раз меняется знак в данной последовательности чисел, запомнить номера позиций, в которых происходит смена знака.

Читайте также

в паскале abc помогите написать программу.

Дано натуральное число N. С клавиатуры вводятся N дат рождения в
формате DD.MM.YYYY (например, 17.04.2014). Напечатать название месяца, в
котором больше всего дней рождений. Если таких месяцев несколько, то
напечатать название самого позднего из них.

написать программу и блок схему

дана матрица
А= {-10 20 13
-22 11 -5
4 12 -8}
определить среднее арифметическое отрицательных и положительных элементов

"Шифры замены". Каждая буква алфавита может быть заменена любым числом из соответствующего столбика кодировочной таблицы.А Б В Г Д Е Ж З И К Л М Н О П Р

21 37 14 22 01 24 62 73 46 23 12 08 27 53 35 04
40 26 63 47 31 83 88 30 02 91 72 32 77 68 60 44
10 03 71 82 15 70 11 55 90 69 38 61 54 09 84 45

С Т У Ф Х Ц Ч Ш Щ Ъ Ы Ь Э Ю Я
20 13 59 25 75 43 19 29 06 65 74 48 36 28 16
52 39 07 49 33 85 58 80 50 34 17 56 78 64 41
89 67 93 76 18 51 87 66 81 92 42 79 86 05 57
Рис. 4.


Какие сообщения закодированы с помощью этой таблицы?16 55 54 10 69 09 61 89 29 90 49 44 10 08 02 73 21 32 83 54 74
41 55 77 10 23 68 08 20 66 90 76 44 21 61 90 55 21 61 83 54 42
57 30 27 10 91 68 32 20 80 02 49 45 40 32 46 55 40 08 83 27 17



Вы находитесь на странице вопроса "20-04-2014 11:01:55", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.