Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано целое число N (> 1) и набор из N чисел. Найти максимальную сумму двух

5-9 класс

соседних чисел из данного набора.10 минут ждууу ...........

Kuller00 08 марта 2017 г., 14:51:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Laurabukenbaeva
08 марта 2017 г., 16:28:38 (7 лет назад)

uses crt;
const n = 5;
var a:array[1..n] of integer;
i,max:integer;
begin
for i:=1 to n do
readln(a[i]);
max = a[1]+a[2];
for i:=1 to n-1 do
if (a[i]+a[i+1] > max) then
max:= a[i]+a[i+1];
writeln(max);
end.

+ 0 -
Tyshinanastia2
08 марта 2017 г., 19:13:12 (7 лет назад)

Готово................

+ 0 -
STEAM1394
08 марта 2017 г., 21:44:29 (7 лет назад)

Паскаль?

+ 0 -
Nevidimka001
08 марта 2017 г., 23:56:05 (7 лет назад)

да

+ 0 -
Lerkalerha
09 марта 2017 г., 0:51:14 (7 лет назад)

поможешь ?)

+ 0 -
Зае4к
09 марта 2017 г., 2:26:23 (7 лет назад)

срочно надо)

Ответить

Другие вопросы из категории

Ученик в первый день выучил 5 английских слов,В каждый следующий день он выучивал на 2 слова больше чем в предыдущее.Сколько английских слов выучит ученик

в 10 день занятий.Сколько всего слов выучит за 10 дней.ОЧЕНЬ СРОЧНО НУЖНО СОСТАВИТЬ АЛГОРИТМ ПО ЭТОЙ ЗАДАЧЕ!!!!!

какие насители информации есть

Читайте также

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

Составить программы в Turbo Pascal. 1)Дано три точки A,B,C на числовой оси.Найти длинну отрезка AC и BC и их сумму. 2)Задано четыре целых числа

a,b,c,d.Выяснить произведение этих чисел больше 300? 3)Дано целое число ,если оно положительное,то прибавить к нему 1,а если отрицательное.то отнять от него 2.Вывести полученое число.

1.Дано целое число,лежащее в диапазоне 1-999.Вывести его строку-описание вида "четное двузначное число","нечетное трехзначное число" и т.д.

2.Даны 3 переменные вещественного типа:А,В,С.Если их значения упорядочены по возрастанию,то удвоить их.В противном случае заменить значение каждой переменной на противоположное.Вывести новые значения переменных А,В,С.
3. Даны 3 целых числа,одно из которых отлично от двух других,равных между собой. Определить порядковый номер числа,отличного от остальных.



Вы находитесь на странице вопроса "Дано целое число N (> 1) и набор из N чисел. Найти максимальную сумму двух", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.