Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найти сумму чисел четырехзначного числа(решить с циклом пост условия)СРОЧНО!!!

5-9 класс

Музо 18 июля 2013 г., 7:27:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
TheMarkDj12
18 июля 2013 г., 8:03:03 (10 лет назад)

var a,s:integer;
begin
readln (a);
repeat
s:=s+a mod 10;
a:=a div 10;
until a=0;
writeln (s);
end.

Ответить

Другие вопросы из категории

помогите посчитать

1 11001+ 1011
2 1111+ 111
3 1000 - 11
4 101000 - 10101
5 10110 - 1110

Ааааааа... Вопрос жизни и смерти, помогите, пожааааалуйста!

Внимательно рассмотрите блок-схему. Сформулируйте в словесной форме признак, о котором в ней идёт речь.

Царевна лягушка съедает ежедневно на 20 % комаров больше, чем в предыдущий день, и ещё 2 комара. Написать программу, определяющую, через сколько дней

количество съеденных комаров превысит 100 , если в первый день было съедено 12 комаров. Составьте программ

Читайте также

1.С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел.

(Тема:Программирование ветвлящихся и цепленных алгоритмов)
2.Дано двухзначное число,найти сумму и произведение его чисел.
(2-ая задача решается с div и mod)
(Тема:Программирование ветвлящихся и цепленных алгоритмов )

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 5.



Вы находитесь на странице вопроса "Найти сумму чисел четырехзначного числа(решить с циклом пост условия)СРОЧНО!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.