Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана последовательность чисел а1,а2,...,а15, упорядоченная по возрастанию, и число n1, не равное ни одному из чисел последовательности, и такое что

5-9 класс

а1<n1<a15.
Определить сумму последовательности, меньших n1.

Temerok 09 сент. 2014 г., 20:01:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elena32
09 сент. 2014 г., 20:54:52 (9 лет назад)

program z;
var a:array [1..15] of integer; i,k,s,j,n:integer;
begin

writeln('Начальная последовательность');
for i:=1 to 15 do
begin
a[i]:=random(1,100);
write(a[i], ' ');
end;
for j:=1 to 14 do
for i:=1 to 14 do
if a[i]>a[i+1] then
begin
k:=a[i];
a[i]:=a[i+1];
a[i+1]:=k
end;
writeln;
writeln('Отсортированная последовательность');
for i:=1 to 15 do
write(a[i], ' ');
writeln;
write('Введите N (а[1]<N<a[15]) ');
read(n);
for i:=1 to 15 do
begin
if (a[i]=n) or (a[1]>n) or (a[15]<n) then
begin
while (a[i]=n) or (a[1]>n) or (a[15]<n) do
begin
writeln('Ошибака! Число N не длжно совпадать с элементами последвовательности и а[1]<N<a[15]');
write('Введите N (а[1]<N<a[15]) '); read(n);
end;
end;
if a[i]<n then s:=a[i]+s;
end;
write('Cумму последовательности меньших N = ',s);
end.

Ответить

Читайте также

1.Напишите программу расчёта площади прямоугольника,если известны его периметр и длина одной из сторон. Входные данные вводятся пользователем с экрана.

Вывод так же осуществляеться на экран.
2.Дана последовательность чисел а,b,c. Все отрицательные числа заменить на нули. Входные данные вводятся пользователем с экрана. Вывод так же осуществляется на экран.
Нужно составить вроде таблицу алгоритмов,помогите пожалуйста.
Я не прошу схемотично,хотя бы описание,где что должно быть написано,очень надо,помогите

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

Дан массив из N целых чисел a1,a2...,aN.Вам нужно проверить,есть ли в этом массиве три числа сумма которых равно нулю.

Формат входных данных

В певой строке входного файла содержится одно целое число n(1<=n<=200).Во второй строке находятся n целых чисел a1,a2...aN (-1000<=ai<=1000)-елементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES",если в этом массиве есть три числа сумма которых равна нулю.Иначе выведите "NO".

Помогите решить задачу на любом языке программирования.

Имеется ряд из N лампочек, которые пронумерованы от 1 до N. Изначально ни одна из лампочек не горит. Далее происходит K последовательных линейных инверсий этого ряда ламп. Под линейной инверсией понимается инверсия каждой P-й лампочки в ряде. Например, если P=3, то произойдет инверсия 3й, 6й, 9й и т.д. лампочек.Требуется определить: сколько горящих лампочек останется после реализации всех заданных линейных инверсий?

Входные данные:
В первой строке входного файла INPUT.TXT заданны числа N и K – число лампочек и число линейных инверсий. Вторая строка состоит из K целых чисел Pi, задающих период данных инверсий. (1 <= N <= 109, 1<=K<=100, 1 <= Pi <= 50)



Вы находитесь на странице вопроса "Дана последовательность чисел а1,а2,...,а15, упорядоченная по возрастанию, и число n1, не равное ни одному из чисел последовательности, и такое что", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.