Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 981 ответов!

Задача на динамическое программирование. Дано число N. Нужно вычислить N-ое число Фибоначчи (Первое - 1, второе - 1, третье - 2, четвертое - 3,

10-11 класс

...).

тетрадочка5666666 03 дек. 2016 г., 18:25:59 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ингааа
03 дек. 2016 г., 20:29:48 (7 лет назад)

VAR
   n, i, f1, f2, f3: LongInt;
BEGIN
   Read(n);
   f3 := 1;
   for i := 1 to n do begin
      f1 := f2; f2 := f3;
      f3 := f1 + f2; end;
   Write(f3);
END.

Ответить

Другие вопросы из категории

Народ помогите 4 решить...
Разработать программу, реализующую следующий функционал: 1.1. Программа запрашивает у пользователя число от 1 до 10 (n). 1.2. Программа

проверяет введенное число на правильность: больше либо равно 1 и меньше либо равно 10.

1.3. Если введенное число попадает в диапазон 1÷10, программа вычисляет произведение последовательности чисел от 1 до n , то есть n! («n факториал»). Результат вычисления выдается в виде сообщения пользователю.

1.4. Если введенное число не попадает в диапазон от 1 до 10 включительно, то программа выдает сообщение об ошибке и завершает свое выполнение.

Читайте также

Дано натуральное четырехзначное число. Средствами Microsoft Excel получить число: 1) образуемое при перестановке

первой и второй, третьей и четвертой цифр заданного числа. Например, из числа
5436 получить число 4563.

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Поиск результатов по фразе "A 5. Автомат получает на вход четырёхзначное восьмеричное число. По этому числу строится новое число по следующим правилам. 1.

Складываются первая и вторая, а также третья и четвёртая цифры. 2. Полученные два числа в восьмеричной системе счисления записываются друг за другом в порядке возрастания (без разделителей). Пример. Исходное число: 4531. Суммы: 4+5 = 9; 3+1 = 4. Результат: 411. Определите, какое из следующих чисел может быть результатом работы автомата. 1) 117 2) 1213 3) 1511 4) 1517
Здравствуйте.
Необходим ход решение задачи, подробный

Задача на программе АВС паскаль:

Дано число, определите является ли оно двухзначным и кратным 2 и 6

P.S. должно решаться через мод



Вы находитесь на странице вопроса "Задача на динамическое программирование. Дано число N. Нужно вычислить N-ое число Фибоначчи (Первое - 1, второе - 1, третье - 2, четвертое - 3,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.