Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Написать программу на Паскале. Дано четырехзначное натуральное число. Найти количество цифр данного числа, большие цифры А (А вводит пользователь) и

10-11 класс

определить, верно ли, что данное число кратно 3.

Featchew 27 сент. 2014 г., 20:59:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rexthzdfz
27 сент. 2014 г., 23:16:06 (9 лет назад)

var
  i,s:integer;
  x,a:string;
begin
write('Введите четырехзначное число: ');
readln(x);
write('Введите цифру: ');
readln(a);
for i:=1 to 4 do if a=x[i] then s:=s+1;
writeln('Эта цифра встречается ',s,' раз');
if StrToInt(x) mod 3=0 then 
   writeln('Число кратно 3') 
   else writeln('Число не кратно 3')
end.

Ответить

Другие вопросы из категории

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

решите в еxel .

//////////////
2x +y +34z = 1 внизу

Два натуральных числа называются "дружественными", если каждое из них равно сумме всех делителей другого, за исключением его самого (таковы, например,

числа 220 и 284). Напечатать все пары "дружественных" чисел, не превосходящих заданного натурального числа. (Определить функцию, вычисляющую сумму делителей числа.)сделать в C# (си шарп)Помогите пожалуйста)

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

СРОЧНО!!!!!!!!!!!!!!!!!!Написать программу в паскале + составить блок-схемы:

4)Если целое M делится на целое число NБ то на экран выводится частное от деления,в противном случае выводится сообщение"M на N нацело не делится".
8)Одинаковы ли цифры данного двухзначного числа.
9)является ли сумма цифр двухзначного числа четной.
12)кратна ли числу A сумма цифр двухзначного числа.
14)какая из цифр трехзначного числа больше: первая или вторая.
16) все ли цифры трехзначного числа одинаковые.

Помогите написать программу на паскале по этой задаче.

Ввести 3 числа,найти их сумму,произведение и среднее арифметическое.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "Написать программу на Паскале. Дано четырехзначное натуральное число. Найти количество цифр данного числа, большие цифры А (А вводит пользователь) и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.