Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано натуральное число n (n<99999). Найти среднеквадратичное значение цифр этого числа.

10-11 класс

Нужна программа в паскале

Xaritonova02 30 апр. 2014 г., 20:49:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Panushkinalera
30 апр. 2014 г., 22:52:15 (10 лет назад)

var
  x: real;
  y: integer;
  i, k: byte;

begin
  readln(y);
  k := length(inttostr(y));
  x := 0;
  foreach o: char in inttostr(y) do
    x += sqr(strtofloat(o));
  x *= 1 / k;
  writeln(sqrt(x));
end.

Ответить

Читайте также

Разделите точками цифры этого числа группами по три , начиная справа.

Программа получает на вход натуральное число , содержащее не более 100 цифр.
Программа должна вывести то же число , с точками между некоторыми цифрами этого числа.

Примеры входных и выходных данных

Ввод 1000 1.000
Вывод 12345678 12.345.678


Срочно! Дано трехзначное число. Если сумма цифр этого числа превышает 15, то вывести эту сумму. Иначе вывести

произведение цифр этого числа.

Необходимо решение на языке Паскаль. Заранее спасибо!

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число



Вы находитесь на странице вопроса "Дано натуральное число n (n<99999). Найти среднеквадратичное значение цифр этого числа.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.