Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Срочно! Дано трехзначное число. Если сумма цифр этого числа превышает 15, то вывести эту сумму. Иначе вывести

10-11 класс

произведение цифр этого числа.

Необходимо решение на языке Паскаль. Заранее спасибо!

XMSx 05 окт. 2014 г., 20:29:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastyaaff97
05 окт. 2014 г., 23:05:35 (9 лет назад)

var a: integer;

     s,s1: integer;

begin

  readln(a);

  s:=(a div 100)+((a mod 100) div 10)+((a mod 100) mod 10);

  s1:=(a div 100)*((a mod 100) div 10)*((a mod 100) mod 10);

  if s>15 then writeln(s) else writeln(s1);

end.

Ответить

Другие вопросы из категории

укажите логические высказывания. какое значение они имеют?

а) трижды три равно четырем.
б) ты уже пришел?
в) калькулятор предназначен для вычислений.
г) привет!

Контрольная помогите срочно !!

Написать программу натурального числа n в квадрате , используя следующую закономерность n в квадрате =1+3+5+7.....+(2n-1)

Читайте также

Разделите точками цифры этого числа группами по три , начиная справа.

Программа получает на вход натуральное число , содержащее не более 100 цифр.
Программа должна вывести то же число , с точками между некоторыми цифрами этого числа.

Примеры входных и выходных данных

Ввод 1000 1.000
Вывод 12345678 12.345.678


Доброго времени суток, помогите пожалуйста с решением данной задачи, необходим код, для Turbo Pascal. Сама задача звучит так:

С клавиатуры вводится 3 числа, если сумма первого и последнего больше 10, то вывести эту сумму, если произведение больше 20, но меньше 30 (20>>30) то вывести это произведение, в противном случае вывести все эти 3 числа.

СРОЧНО!!!!!!!!!!!!!!!!!!Написать программу в паскале + составить блок-схемы:

4)Если целое M делится на целое число NБ то на экран выводится частное от деления,в противном случае выводится сообщение"M на N нацело не делится".
8)Одинаковы ли цифры данного двухзначного числа.
9)является ли сумма цифр двухзначного числа четной.
12)кратна ли числу A сумма цифр двухзначного числа.
14)какая из цифр трехзначного числа больше: первая или вторая.
16) все ли цифры трехзначного числа одинаковые.

1)составить блок-схему поиска двузначных чисел,таких,что если к сумме цифр этого числа прибавить квадрат этой суммы,то получится это число.

2)построить блок схему которая меняет порядок цифр числа на обратный. например было 12345,стало 54321.



Вы находитесь на странице вопроса "Срочно! Дано трехзначное число. Если сумма цифр этого числа превышает 15, то вывести эту сумму. Иначе вывести", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.