Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 981 ответов!

Опять-таки нужна программа в среде паскаль

10-11 класс



На
вход поступает первое число - колличество чисел в
последовательности.Затем вводится последовательность.Подсчитать сумму
чётных чисел больше 30 в последовательности.

Ktybhndj 29 апр. 2014 г., 8:00:10 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КАТЮША2004ГОД
29 апр. 2014 г., 8:41:41 (10 лет назад)

var
  len, number, i, sum : integer;
begin
  write('Количество чисел: ');
  readln(len);
  sum := 0;
  for i := 1 to len do
  begin
    read(number);   {считываем введённое число}
    if ((number mod 2 = 0) and (number > 30)) then   {проверяем, является ли введённое число чётным и больше ли оно 30}
      sum := sum + number;      {увеличиваем сумму на это число}
  end;
  writeln('Сумма = ', sum);
end.

Ответить

Другие вопросы из категории

Построить таблицу истинности:

>(A \/ >C) ->(C . B)

К hardwere относят:

1) программное обеспечение
2) схемы ОЗУ
3) архиватор
4)браузер
5)плоттер
6)стример
К software относят:
Печатающее устройства
Сканирующий устройства драйверы
Аппаратное обеспечение утилиты
Программы копировани

Читайте также

Программисты хэлп.

Условия: составить алгоритм разветв. структуры
Нужна программа на языке паскаль

Ребята, девчата, тут такое затруднение. Нужна программа в паскале, только в паскале.

Условие:
Напишите программу которая вычисляет среднее арифметическое элементов таблицы А(3*8) . Программа по двумерным массивам.

В PascalABC нужно написать такого рода программу:

Написать программу для нахождения среднего арифметического модулей двух чисел.

Здравствуйте! Позарез нужна программа в Паскале, вот условие:

"Разработать программу,
которая осуществляет в текстовом файле поиск заданных слов. Слова
последовательно вводятся с клавиатуры. Для каждого слова должно определяться
количество вхождений и номера строк текста. Если указанное слово в файле
отсутствует, то программа должна выводить соответствующее сообщение."
И если можно, то и блок-схему.
Заранее спасибо!

Помогите пожалуйста в среде паскаль решить такую задачу:

посчитать сколько нечетных цифр в н - значном числе! (паскаль)



Вы находитесь на странице вопроса "Опять-таки нужна программа в среде паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.