Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль, задача приложена в изображении 5.55(б), помогите, пожалуйста.

10-11 класс

Оператор цикла с параметром.

Jbresheva93 20 мая 2014 г., 6:01:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Coolday
20 мая 2014 г., 7:28:26 (9 лет назад)

На всякий случай я ещё выложу правильное решение второй задачи( во вложении) либо код здесь:
const n=10;
var mas:array[1..n] of integer;
i,x:integer;
begin
  x:=1;
  for i:=1 to n do
    begin
      write('Input a[',i,']='); 
      readln(mas[i]); 
      x:=x*abs(mas[i]);
    end;
  writeln('the answer is:', x);readln;
end.

Вариант из первого решения предложенного вам не скомпилируется, потому что не объявлена константа n. Кроме того в нем нет вывода ответа и непонятно, что за числа надо вводить с клавиатуры (в моем примере оно спросит input a[1] = 

+ 0 -
кристиналис
20 мая 2014 г., 9:28:24 (9 лет назад)

1 задачка
var mas:array[1..n] of integer; i,x:integer;
begin
x:=0;
for i:=1 to n do
 begin
  readln(mas[i]);
  x:=x+abs(mas[i]);
 end;
end.

2 задачка

var mas:array[1..n] of integer; i,x:integer;
begin
x:=1;
for i:=1 to n do
 begin
  readln(mas[i]);
  x:=x*abs(mas[i]);
  end;
 end.

+ 0 -
Nanish04
20 мая 2014 г., 12:13:45 (9 лет назад)

как срочно надо? )

+ 0 -
Каssандра
20 мая 2014 г., 14:40:24 (9 лет назад)

до завтра)

+ 0 -
Danchina
20 мая 2014 г., 16:23:57 (9 лет назад)

Решение почти правильное вам дали, я поправил ошибки и выложил

+ 0 -
Sany18
20 мая 2014 г., 18:11:37 (9 лет назад)

Еще забыл указать :) на тесте вводите маленькие числа (от 1 до 10, например, чем меньше, тем лучше) и только целые. потому что произведение быстро нарастает, если введете большие числа программа вылетит с ошибкой переполнения

Ответить

Другие вопросы из категории

Срочно!!!Помогите пожалуйста! Всем известно, что «от перестановки слагаемых сумма не изменяется». Однако, случается и так, что перестановка двух чисел

приводит к более интересным последствиям.

Пусть, например, заданы три числа: a1, a2, a3. Рассмотрим равенство a1+ a2= a3. Оно может быть неверным (например, если a1= 1, a2= 4, a3= 3), однако может стать верным, если поменять некоторые числа местами (например, если поменять местами a2 и a3, оно обратится в равенство 1 + 3 = 4).

Ваша задача – по заданным трем числам определить: можно ли их переставить так, чтобы сумма первых двух равнялась третьему.

Входные данные

Входной файл INPUT.TXT содержит три целых числа: a1, a2, a3 (−108 ≤ a1, a2, a3 ≤ 108).

Выходные данные

В выходной файл OUTPUT.TXT выведите слово «YES», если заданные числа можно переставить так, чтобы сумма первых двух равнялась третьему. В противном случае выведите в выходной файл слово «NO».

Опять-таки нужна программа в среде паскаль



На
вход поступает первое число - колличество чисел в
последовательности.Затем вводится последовательность.Подсчитать сумму
чётных чисел больше 30 в последовательности.

Построить таблицу истинности:

>(A \/ >C) ->(C . B)

Читайте также

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите пожалуйста с задачей по информатике!Без массива!Напишите в паскале!Очень надо!!

Опишите этапы решения на компьютере задачи нахождения значения a^b для целых чисел 0<a,b<10.

Помогите пожалуйста в среде паскаль решить такую задачу:

посчитать сколько нечетных цифр в н - значном числе! (паскаль)

Помогите пожалуйста в среде паскаль решить такую задачу:

определить сколько цифр в н- значном числе!!!! (паскаль)

Помогите, пожалуйста, решить задачи в паскале :

1.Определите сколько нечетных чисел среди четырех заданных чисел
2.Вычислите, является ли четырехзначное число счастливым



Вы находитесь на странице вопроса "Паскаль, задача приложена в изображении 5.55(б), помогите, пожалуйста.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.