Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

декодируйте сообщения

5-9 класс

жуцёг льл, г ргмжиыя- дзузёл
фхгуюм жуцё оцъыз рсеюш жецш.

Nika123476 10 июня 2014 г., 19:10:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Asyaborisenko
10 июня 2014 г., 20:53:33 (9 лет назад)

Друга ищи, а найдешь - береги
Старый друг лучше новых двух

Ответить

Другие вопросы из категории

вид главного меню
помогите,пожалуйста))напишите блок-схему к этой программе(одномерные массивы)язык программирования-Паскаль.

Программа:
var a, b:array [1..15] of integer;
i, max, min, j1, j2, sum, k:integer;

begin
write('Измерения ростов всех студентов ');
randomize;
for i:=1 to 15 do
begin
a[i]:=random(50)+140;
write ('а[',i,']-',a[i],';');
end;
writeln;
write('Рост самого высокого студента (номер): ');
max := 0;
min := 65535;
k := 0;
sum := 0;
for i := 1 to 15 do
begin
if (a[i] > max) then begin max := a[i]; j1 := i; end;
if (a[i] < min) then begin min := a[i]; j2 := i; end;
sum := sum + a[i];
if (a[i] > 170) then
begin
inc(k);
b[k] := a[i];
end;
end;
writeln(j1);
write('Рост самого низкого студента (номер): ');
writeln(j2);
write('Средний рост: ');
writeln(sum/15:4:2);
write('Массив b:');
for i := 1 to k do write('B[',i,']',b[i], ';');
readln;
end.
Вывод:
Измерения
ростов всех студентов
а[1]-159;а[2]-183;а[3]-176;а[4]-168;а[5]-156;а[6]-165;а[7]-187;а[8]-144;а[9]-162;а[10]-164;а[11]-142;а[12]-158;а[13]-159;а[14]-163;а[15]-182;
Рост самого высокого студента (номер): 7
Рост самого низкого студента (номер): 11
Средний рост: 164.53
Массив b:B[1]183;B[2]176;B[3]187;B[4]182;
буду очень благодарна))

Читайте также

декодируйте сообщения

жуцёг льл, г ргмжиыя- дзузёл
фхгуюм жуцё оцъыз рсеюш жецш.

Информационное сообщение объемом 2560 байт содержит

10240 символов. Сколько символов содержит алфавит, при помощи которого было
записано это сообщение?

1.Производится бросание симметричной четырехгранной пирамидки . Какое количество информации мы получаем в зрительном сообщении о ее падении на одну из

граней ?
а)1бит
б)2бита
в)4бита
г)1байт
2.Из непрозрачного мешочка вынимают шарики с номерами , и известно , что информационное сообщение о номере шарика несет 5 битов информации . определить количество шариков в мешочке .
3.Какое количество информации пр игре в крестики-нолики на поле размером 4*4 клетки получит второй игрок после первого ходы первого игрока ?

Информационное сообщение на русском языке, первоначально написанное в 8-битовом коде Windows, было перекодировано в 16-битовую кодировку Unicode. В

результате информационный объем сообщения стал равен 2 Мбайт. Найдите количество символов в сообщении.

1.Для кодирования сообщений решено использовать последовательности разной длины, состоящие из знаков «+» и «-». Сколько различных сообщений можно

закодировать, используя в каждом из них не менее 3-х и не более 7 знаков?
2.В велокроссе участвуют 987 спортсменов. Специальное устройство регистрирует прохождение каждым из участников промежуточного финиша, записывая его номер с использованием минимально возможного количества бит, одинакового для каждого спортсмена. Каков информационный объем сообщения, записанного устройством, после того как промежуточный финиш прошли 60 велосипедистов?
3.Метеорологическая станция ведет наблюдение за температурой воздуха. Результатом измерения является целое число, принимающее значение от –20 градусов до +12 градусов включительно, которое записывается при помощи минимально возможного количества бит.
Станция сделала 120 измерений. Каков информационный объем результатов наблюдений?
4.Метеорологическая станция ведет наблюдение за температурой воды.
Результатом измерения является целое число, принимающее значение от +1 градуса до +32 градусов включительно, которое записывается при помощи минимально возможного количества бит. Станция сделала 160 измерений. Каков информационный объем результатов наблюдений?



Вы находитесь на странице вопроса "декодируйте сообщения", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.