Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать нормальный алгоритм Маркова, чтоб каждый третий символ стирался... например: abaaba - abab

10-11 класс

Vitalikliya 11 авг. 2014 г., 5:50:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
лера134
11 авг. 2014 г., 8:41:00 (9 лет назад)

var a:string;   
n,i,q:integer;
begin  a:=''; 
readln(a); 
n:=length(a);
 writeln(n); 
q:=0; for i:=1 to n do begin 
q:=q+1; 
if q=3 then begin 
 delete(a,i,1); 
 q:=1; 
 end;
 end; 
 writeln(a);
end. 

+ 0 -
Tuchkina2002
11 авг. 2014 г., 9:53:42 (9 лет назад)

Вот что-то похожее на Паскале:

+ 0 -
Vlasenkovitalij
11 авг. 2014 г., 12:06:47 (9 лет назад)

спасибо)) но мне надо не в программе, а именно написать алгоритм Маркова((

+ 0 -
Ildar2232
11 авг. 2014 г., 14:13:58 (9 лет назад)

Комментарий удален

+ 0 -
Амелия
11 авг. 2014 г., 14:46:26 (9 лет назад)

Комментарий удален

+ 0 -
кид12
11 авг. 2014 г., 15:37:22 (9 лет назад)

Ладно,извините.

Ответить

Другие вопросы из категории

Помогите,пожалуйста,с информатикой.

1)Сканируется цветное изображение стандартного размера А4(21*29,7 см).Разрешающая способность сканера 1200 dpi,глубина цвета 24 бита.Какой информационный объем будет иметь полученный графический файл?
2)Определить длительность звукового файла,который уместится на гибкой дискете 3,5"(для хранения данных на дискете выделяется 2847 секторов объемом 512 байтов каждый):
при низком качестве звука:моно,8 битов,8кГц;
при высоком качестве звука:стерео,16 битов,48 кГц.Просьба написать с объяснением!

Два товарища Миша и Петр пошли в тир. Они стреляют по мишенях, которые расположены в один ряд. Миша стреляет по мишенях с лева направо, а Петр с права

налево.В какой то момент времени случилось так, что они попали в одну мишень. После этого они остановились и решили посчитать, во сколько мишеней каждый из них не стрелял. М и Р - количество мишеней, в какие попали Миша и Петр соответственно.
М+Р меньше или равняется 100
Нужно найти два числа - количество мишеней в какие не стреляли Миша и Петр.

Читайте также

Задача A Доска Задается N. Нужно вывести цвет каждой клетки доски N x N,

если известно, что они покрашены в шахматном порядке и клетка (1, 1) - белая.

Формат входных данных

Первая строка входного файла содержит единственное целое N (1 <= N <= 10).

Формат выходных данных

Выведите N строк в каждой N символов соответствующий цвету этой ячейки: ‘W’ – если белая и ‘B’ – если черная.

Написала код алгоритма в Visual Basic, который правильно считает элементы массива А, В, С и почему то не правильно считает Z по формуле с этими найденными

числами. В чём ошибка? вот код:
Private Sub Command1_Click()

' Описание переменных
Dim N As Single
Dim M(15) As Single
Dim A As Single
Dim B As Single
Dim C As Single
Dim Z As Single
' Описание переменных
' Вод исходных данных
N = 0
M(I) = 0
A = 1
B = 0
C = 0
' Ввод исходных данных

' Реализация алгоритма
For I = 1 To 15
N = Int(Text1.Text)
M(I) = Val(InputBox("Ввести элементы"))
Print Str(M(I))
Next I
For I = 1 To 15
If M(I) > 0 And M(I) <> 0 Then
A = A * M(I)
End If
Next I
For I = 15 To 0 Step -1
If I Mod 2 = 0 Then
If M(I) > 0 Then
B = M(I)
I = 0
End If
End If
Next I
For I = 1 To N Step 1
S = S + M(I)
Next I
C = S / N
Z = С + (А + В/ А * В + 1)
' Реализация алгоритма

' Вывод результата
Text2.Text = Str(A)
Text3.Text = Str(B)
Text4.Text = Str(C)
Text5.Text = Str(Z)
' Вывод результата
End Sub



Вы находитесь на странице вопроса "написать нормальный алгоритм Маркова, чтоб каждый третий символ стирался... например: abaaba - abab", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.