Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Паскаль. Даны три вещественных числа. Вывести на экран те их них, которые принадлежат интервалу (1,6 -

10-11 класс

3,8).

Djhudoy1997 23 мая 2013 г., 9:52:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ol3gg
23 мая 2013 г., 11:48:35 (10 лет назад)

var
  a: array[1..3] of real;
  i, n: integer;

begin
  Write('Введите через пробел три любых числа: ');
  Readln(a[1], a[2], a[3]);
  for i := 1 to 3 do
    if (a[i] >= 1.6) and (a[i] <= 3.8) then Writeln(a[i])
end.

Введите через пробел три любых числа: 13.43 2.41 -1.34
2.41


Ответить

Другие вопросы из категории

Определить является ли целая часть числа m/n

четной. Если она четная,
то m возвести в квадрат, иначе n утроить.

6. Написать программу для нахождения числа нечетных элементов в массиве из 10 беззнаковых чисел.

7. Написать программу для нахождения числа отрицательных элементов в массиве из 10 знаковых чисел
8. Написать программу для замены всех четных элементов массива из 10 беззнаковых чисел единицами.
9. Написать программу для замены всех нулевых элементов массива из 10 знаковых чисел единицами
10. Написать программу для замены всех троек в массиве из 10 беззнаковых чисел пятерками.

перевести в биты

22 байта
2.перевести в байты
А)15 Кбайт
Б)156Мбайт

3.перевести в килобайт
А)7168 байт
Б)6Мбайт
В)5Гбайт

Читайте также

Даны действительные числа x, y. Вывести на экран то из них, которое меньше.

Даны два символа (латинские буквы). Вывести их на экран в порядке возрастания по алфавиту.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент



Вы находитесь на странице вопроса "Паскаль. Даны три вещественных числа. Вывести на экран те их них, которые принадлежат интервалу (1,6 -", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.