Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

С клавиатуры вводят ряд и слово.Составьте программу ,которая определяет позицию данного слова.

5-9 класс

Katyaprostokatya 31 июля 2014 г., 17:37:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Iuliaandrieiev
31 июля 2014 г., 19:40:45 (9 лет назад)

Var c: Char;
s: String;
i,k,p: Integer;
Begin
ReadLn(c); {Чтение заданного символа}
ReadLn(s); {Чтение заданного слова}
p:= Pos(c,s); {Определяем позицию символа}
If (p=0) Then {Функция вернёт 0, если символ не будет найден}
WriteLn('Такого символа в слове нет.')
Else {Если символ есть, то ...}
Begin
WriteLn('Указанный символ расположен на позиции: ',p);
k:= 0; {k хранит количество вхождений}
p:= Length(s); {p хранит длину строки(слова)}
For i:=1 To p Do {Пробегаем по всем символам слова}
If (s[i]=c) Then inc(k); {Если символ совпадает, увеличиваем на 1 переменную k}
WriteLn('Количество вхождений данного символа: ',k);
End;
End.

Ответить

Читайте также

составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них

1.Составить программу, которая определяет номера позиций символа","

2. Составить программу, которая позволяет заменить все гласные символом "*"

1.Дано целое число составить программу которая определяет оканчивающие данное число цифрой семь.

2.Дано 2х значное число составить программу с помощью которой можно отпределить входит ли в это число цифра шесть.

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

1)составьте программу ,которая предлагает ввести с клавиатуры две строки ,а затем выводит это строки на экран в алфавитном порядке

например армия(строка а)
арбуз (строка б)
2)составьте программу ,которая предлагает ввести с клавиатуры две строки а и б ,соеденяет их и выводит результат в одну строку
например: тепло(строка а)
ход(строка б)



Вы находитесь на странице вопроса "С клавиатуры вводят ряд и слово.Составьте программу ,которая определяет позицию данного слова.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.