Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

На

10-11 класс

рисунке изображена блок-схема. Какое значение будет присвоено переменной X
после выполнения алгоритма? решите
задачу, решение отразите в отчете

Kat9988 26 февр. 2017 г., 11:52:53 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Wellary25
26 февр. 2017 г., 13:07:13 (7 лет назад)

program abc;
var a,b,c,x :integer;
begin
read(a,b,c);
x:= a;
if x<=b then
x:=b;
else
begin
if x<=c then 
x:=c;
end;
write (x);
end. 

Ответить

Другие вопросы из категории

Помогите пожалуйста с паскалем!

В компьюьтер с клавиатуры вводятся 11 целых чисел. Посчитать произведение чисел, кратных 5 и оканчивающихся цифрой 0.

1.Составить блок-схему,которая определяет сумму двузначных четных чисел

2.Составить программу вычисления уравнения : y= \frac{1}{z} + \frac{5}{z-6}
предусматрев вариант,при каких Z, уравнение не имеет решения

1 Скрин . Задание со хемами

2. Скрин . задание №6 ( печать отвратительная , в 1 пункте над В 2 штриха - длинный и кототкий , и в пункте 3 такие же штрихи над А
3. Скрин 3 . Задание №1 ... как ? как правильно преобразовывать величины информации??

( а лучше обьясните как это решать? в школе по информатике только писали про мышки , клавы и т.д , сейчас вступительные и приходится все самостоятельно осваивать ... в принципе уже все освоил , но проблемы с данным заданиями)

заранее благодарен

Читайте также

1)Определите длительность звукового файла, который уместится на дискете 3,5"

при высоком качестве звука (16 бит, 48 кГц).Учтите, что для хранения данных на такой дискете выделяется 2847 секторов объёмом 512 байт каждый (ход решения)

2)Вычислить информационный объём текстового документа в Мбайт( с точность до сотых)
и узнать,сколько дискет 3,5 дюйма объёмом 1,44 мб понадобится для переноса англо-русского словаря,который содержит 604 страницы ( 89 символов в строке, 66 строк на странице) (ход решения)

1) В компьютер вводится результат для 10 абитуриентов. Вывести на экран фамилии и результат тех, кто попадает в интервал ( 10, 30) Подсчитать среднее

арифметическое.
2) Дан массив из 10 элементов. Определить 2х значные числа и которые заканчиваются на цифре 5.

Здравствуйте ребят! Помогите решить задачку..Мне её надо написать в С++. Честно говоря хотя бы напишите мне "Дано" и как это решить. На

острове каждый год появляется сундук с 100 кг золотого песка, к острову с одной стороны высаживается х пиратов, а с другой у матросов. Они дерутся за клад, в битве погибает 70% участников, 26% тяжело ранены. Монеты делятся среди оставшихся 4%. Определить количество победителей, тяжелораненых, погибших, а также количество золотого песка на 1 человека .

Документ объёмом 8 Мбайт можно передать с одного компьютера на другой

двумя способами:
А) сжать архиватором, передать архив по каналу связи, распаковать;
Б) передать по каналу связи без использования архиватора.
Какой способ быстрее и на сколько, если:
• скорость передачи данных по каналу связи составляет 221 бит/с;
• объём сжатого архиватором документа равен 50 % от исходного;
• время, требуемое на сжатие документа, – 10 секунд, на распаковку –
3 секунды?
В ответе напишите букву А, если быстрее способ А, или Б, если быстрее
способ Б. Сразу после буквы напишите число, обозначающее, на сколько
секунд один способ быстрее другого.
Так, например, если способ Б быстрее способа А на 23 секунды, в ответе
нужно написать Б23.
Единицы измерения «секунд», «сек.», «с» к ответу добавлять не нужно.

Помогите решить задачку очень-очень надо:)) спасибо:* Устав от повседневных дел, Иван Петрович устроил себе отпуск - пошел на охоту. На

расстоянии N метров, его охотничья собака Гайзарда заметила зайца. Через какое время она догонит его если скорость зайца V1 м / с, а скорость собаки V2 м / с? Следует отметить, что Гайзарда бегает быстрее любого зайца.
Входные данные:
Программа на вход получает три целых числа N, V1, V2 (0 ≤ N ≤ 103, 0 <V1, V2 <20).
Выходные данные:
Программа должна вывести время за собака догонит зайца с точностью до сотых.



Вы находитесь на странице вопроса "На", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.