Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана последовательность из М чисел. Подсчитать, сколько в ней отрицательных, положительных и нулевых элементов

10-11 класс

Guhdrhghgfdhg 07 янв. 2015 г., 20:37:58 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastyakakayato
07 янв. 2015 г., 21:54:36 (9 лет назад)

var a:array [1..M] of integer;

      i, p, k, n, M:integer;

begin

p:=0;

k:=0;

n:=0;

readln(M);

for i:=1 to M do

readln (a[i]);

for i:=1 to M do

if a[i]>0 then p:=p+1 else

    if a[i]<0 then k:=k+1 else n:=n+1;

writeln (p, k, n);

end.

Ответить

Другие вопросы из категории

Поле шахматной доски представляется парой натуральных чисел, каждое из которых не превосходит восьми: первое число - номер вертикали (при счете снизу

вверх), второе - номер горизонтали (при счете слева направо). Даны натуральные числа k, l, m,n, каждое из которых не превосходит восьми. Требуется:

1. выяснить, являются ли поля (k, l) и (m, n) полями одного цвета

2. на поле (k, l) расположен ферзь. Угрожает ли он полю (m, n)?

задача в Delphi.

Некоторая вещь стоит A рублей и B копеек. Было куплено N таких вещей. Запишите общую стоимость покупки в рублях и копейках в переменные C1 и С2. Значения

переменных A и N не превосходят 30000, а значение переменной B не превосходит 100. Переменные С1 и С2 имеют тип longint. Другие переменные не использовать.

Читайте также

дан массив действительных чисел,размерность которого N.

Подсчитать,сколько в нем отрицательных,положительных и нулевых элементов. Программа в паскаль

Составить программу в PASCAL.

Вводится длина вектора и значения его элементов.
1. Подсчитать количество элементов, равных заданному значению.
2. Поменять местами максимальный и минимальный элементы вектора.
3. Подсчитать количество отрицательных, положительных и нулевых элементов вектора.

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Выводится на экран последовательность 20 случайных чисел из промежутка

[-10,10]. Определить количество отрицательных чисел больших -5 в данной
последовательности.



Вы находитесь на странице вопроса "Дана последовательность из М чисел. Подсчитать, сколько в ней отрицательных, положительных и нулевых элементов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.