Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан двумерный массив 7Х5. Найти сумму отрицательных элементов в каждом столбце. Определить минимальный элмент в 1-й строке( значение и

10-11 класс

координаты)

Dubrovskaya 08 июля 2013 г., 5:30:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Коломуся
08 июля 2013 г., 7:58:12 (10 лет назад)

эта задача на нахождение суммы отриц. элементов
Const
N=7; К=5;

+ 0 -
Dasha96096
08 июля 2013 г., 8:40:01 (10 лет назад)

var
  i,j,s,min,im:integer;
  a:array[1..7,1..5]of integer;
begin
for i:=1 to 7 do
  begin
  for j:=1 to 5 do
    begin
    a[i,j]:=random(-9,9);
    write(a[i,j]:4);
    end;
  writeln;
  end;
writeln('Сумма отрицательных по столбцам:');
for j:=1 to 5 do
  begin
  for i:=1 to 7 do
    if a[i,j]<0 then s:=s+a[i,j];
  write(s:4);
  s:=0;
  end;
min:=a[1,1];
for j:=1 to 5 do
    begin
    if (a[1,j]<min) then
      begin
      min:=a[1,j];
      im:=j;
      end;
    end;
writeln;
writeln('Min=',min,'; (1,',im,')');
end.

Ответить

Другие вопросы из категории

В велокроссе участвуют 659 спортсменов. Специальное устройство регистрирует прохождение каждым из участников промежуточного финиша, записывая его

номер с использованием минимального возможного количества бит, одинакового для каждого спортсмена. Каков информационный объём сообщения в битах, записанного устройством, после того как промежуточный финиш прошли 180 велосипедистов?

1)Загадано число от 1 до 100.Загадавший на все вопросы отвечает только "да" или "нет".Какое наименьшее число вопросов нужно задать, чтобы

гарантированно угадать число? 2)В велокроссе участвуют 119 спорстменов.Специальное устройство регистрирует прохождение каждым из участников промежуточного финиша, записывая его номер с использованием минимально возможного количества бит, одинакового для каждого спортсмена.Каков информационный объем в битах сообщения, записанного устройством, после того как промежуточный финиш прошли 70 велосипедистов? Помогите пожалуйста, нужно решение как можно скорее!

Читайте также

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

№1 Дана действительная квадратная матрица порядка n. Найти произведение четных элементов.

№2 В данном одномерном массиве Х[1..n] найти сумму отрицательных элементов , кратных 7.

составить программу 1)найти сумму всех элементов массива (1до10) random. 2)сформировать массив из положительных и отрицательных элементов

от -10 до 30.найти кол-во положит и отриц элементов.найти сумму положит и произведение отриц.

Дан массив X(N).Найти среднее арифметическое элементов массива,значения которых заключены в интервале [-3;3]. Если эта величина больше

заданного числа Z,то найти сумму четных элементов,иначе- произведение нечетных элементов.

Друзья,очень нужна ваша помощь,пожалуйста,если Вы решили мне помочь-отпишитесь. Заранее спасибо!



Вы находитесь на странице вопроса "Дан двумерный массив 7Х5. Найти сумму отрицательных элементов в каждом столбце. Определить минимальный элмент в 1-й строке( значение и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.