Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найти площадь кольца, внешний радиус которого равен R1, а внутренний – R2 (R1>R2). Разработать схему алгоритма для решения этой задачи.

5-9 класс

Протестировать алгоритм для R1=5.6 и R2=3.8. Проверить ответ на калькуляторе.

Starkiller2002 22 нояб. 2013 г., 3:40:19 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
мәди
22 нояб. 2013 г., 5:04:17 (10 лет назад)

Всё собственно в скриншоте.

+ 0 -
091978
22 нояб. 2013 г., 6:16:22 (10 лет назад)

var
    R1, R2: real;

begin
    write('Введите данные - ');
    read(R1, R2);
    writeln('Pi = ', pi); {это чтоб знать с какой точностью брать П}
    writeln('S = ', pi * abs(R1 * R1 - R2 * R2));
end.

Ответить

Читайте также

1. Площадь круга вычисляется по формуле S=3.14*R2 Найти площадь кольца, внешний радиус которого равен R1, а внутренний – R2. Разработать схему

алгоритма для решения этой задачи. Протестировать алгоритм для R1=5.6 и R2=3.8.

ОЧЕНЬ СРОЧНО

Привет, мне нужна помощь с заданием по информатике. С таблицей Pascal.

Написать программу для нахождения площади кольца, внешний радиус которого равен R1, а внутренний R2, (R1>R2). Протестировали программу для R1=5.6 , R2=3.8 . Проверить ответ на калькуляторе

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

Самолёт находился на высоте 5000 метров. Обнаружилась неисправность работы двигателя. Самолёт начал падать. Бортовой компьютер производит диагностику неисп

равности и сообщает пилоту о необходимых действиях. Для решения этой задачи ему нужно выполнить 100000000 вычислительных операций. Быстродействие компьютера - 1 млн. оп./с. Успеет ли лётчик спасти самолёт, если минимальная высота, на которой самолёт можно вывести из пике, - 2000 метров?



Вы находитесь на странице вопроса "Найти площадь кольца, внешний радиус которого равен R1, а внутренний – R2 (R1>R2). Разработать схему алгоритма для решения этой задачи.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.