Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Visual Basic

10-11 класс

Написать процедуру для нахождения отрицательных и положительных чисел из строки, состоящий из произвольного набора цифр и букв.

*перевести полученное число в его двоичный код

*найти максимальное из чисел

Demidtarasenko 11 марта 2015 г., 1:23:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zhenyaapril
11 марта 2015 г., 4:12:55 (9 лет назад)

Язык VBA:

Function Bin(s As String, z As Integer) As String
Dim c As Integer
Dim oct As Integer
c = Val(s)
Do
    oc = c Mod 2
    c = c \ 2
    Bin = Bin & Str(oc)
Loop Until c = 0
Bin = StrReverse(Bin)
If z = -1 Then Bin = "-" & Bin
End Function

Sub z()
Dim s As String, s1 As String
Dim n As Integer, i As Integer, z As Integer
Dim max
s = InputBox("Введите строку: ")
max = Null
i = 1
Do While i <= Len(s)
    Select Case Mid(s, i, 1)
       Case 0 To 9
          If z = 0 And i > 1 Then
             z = IIf(Mid(s, i - 1, 1) = "-", -1, 1)
          Else: z = 1
          End If
          s1 = s1 + Mid(s, i, 1)
          If i = Len(s) Then GoSub 1
       Case Else:
         If s1 <> "" Then GoSub 1
    End Select
    i = i + 1
Loop
MsgBox ("max=" & max)
End
1:          n = z * Val(s1)
             MsgBox (n & "; двоичная форма: " & Bin(s1, z))
             If IsNull(max) Then max = n
             If max < n Then max = n
             z = 0
             s1 = ""
             Return
End Sub

Ответить

Другие вопросы из категории

Требовалось написать программу,при выполнении которой с клавиатуры вводится натуральное число,не превосходящее 10^8, и выводится его первая цифра.Ученик

написал такую программу:
var n:longint;
begin
read(n);
while n>10 do
begin
n:=n mod 10
end;
write(n);
end.


1)Напишите,что выведет эта программа при вводе числа 1984.
2)Приведите пример числа,при вводе которого программа выдаст верный ответ.
3)Найдите в программе все ошибки.

дано натуральное число верно ли что это число четырехзначное

в паскале программу написать

Читайте также

Cрочно! Язык visual basic,массивы - задачи:

1)Заменить значение любого элемента массива на а
2)Определить имеются ли четные числа в массиве
3)Заменить все элементы некоторой строки на заданное число
4)Вывести все элементы N столбца и M строки

Написала код алгоритма в Visual Basic, который правильно считает элементы массива А, В, С и почему то не правильно считает Z по формуле с этими найденными

числами. В чём ошибка? вот код:
Private Sub Command1_Click()

' Описание переменных
Dim N As Single
Dim M(15) As Single
Dim A As Single
Dim B As Single
Dim C As Single
Dim Z As Single
' Описание переменных
' Вод исходных данных
N = 0
M(I) = 0
A = 1
B = 0
C = 0
' Ввод исходных данных

' Реализация алгоритма
For I = 1 To 15
N = Int(Text1.Text)
M(I) = Val(InputBox("Ввести элементы"))
Print Str(M(I))
Next I
For I = 1 To 15
If M(I) > 0 And M(I) <> 0 Then
A = A * M(I)
End If
Next I
For I = 15 To 0 Step -1
If I Mod 2 = 0 Then
If M(I) > 0 Then
B = M(I)
I = 0
End If
End If
Next I
For I = 1 To N Step 1
S = S + M(I)
Next I
C = S / N
Z = С + (А + В/ А * В + 1)
' Реализация алгоритма

' Вывод результата
Text2.Text = Str(A)
Text3.Text = Str(B)
Text4.Text = Str(C)
Text5.Text = Str(Z)
' Вывод результата
End Sub

Программа visual basic

Задание 1.разработайте программу которая будет вычислять площадь трапеции
задание 2.создайте проект который изменит цвет и размер формы



Вы находитесь на странице вопроса "Visual Basic", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.