Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста,очень нужно. Заранее спасибо. Смотрите приложение. Задания по ту Турбо Паскаль.

10-11 класс

Antttoxaru 10 нояб. 2014 г., 7:01:23 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Klochko1
10 нояб. 2014 г., 9:02:03 (9 лет назад)


Program XY1;
uses crt;
var
  x,y: real;
begin
  writeln('Введите координаты точки:');
  write('X='); readln(x);
  write('Y='); readln(y);
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  if (y>=0) and (y>=-x+2) and (x*x+y*y<=9) and (y<=exp((1/2)*ln(abs(x)))) then
    begin
      writeln('Точка (',x,',',y,') попадает в заштрихованную область ');
    end
  else
    writeln('Точка (',x,',',y,') HE попадает в заштрихованную область ');
end.

Program NX2;
uses crt;
var
  x,y: real;
  n,i:integer;
begin
  writeln('Введите число N:');
  write('N='); readln(n);
  writeln('Введите число x:');
  write('x='); readln(x);
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  y:=1;
  for i:=1 to n do
    y:=y*(i/(i+1)-exp(i*ln(abs(cos(abs(x))))));
  writeln('Произведение равно ',y);
end.

Program DX3;
uses crt;
procedure click(x:real;var y:real);
begin
  if x<0 then
      y:=1-exp(3*ln(abs(sin(x))))
    else
      y:=exp(-x);
end;
var
  max,min,sum,temp: real;
  i:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  click(-0.5,min);
  click(-0.5,max);
  sum:=0;
  for i:=-5 to 5 do
    begin
      click(i/10,temp);
      if min>temp then min:=temp;
      if max<temp then max:=temp;
      sum:=sum+temp;
      writeln('x=',i/10:5:1,'    y=',temp:6:3);
    end;
  writeln('Минимальное значение функции на отрезке: ',min:6:3);
  writeln('Максимальное значение функции на отрезке: ',max:6:3);
  writeln('Среднее значение функции на отрезке: ',sum/11:6:3);
end.


Program MAS4;
uses crt;
const n = 10;
const m = 15;
var
  a:array [1..n] of integer;
  b:array [1..m] of integer;
  c:array [1..n+m] of integer;
  k,t,i,j,max: integer;
begin
  {заполняем массивы случайными числами}
  randomize;
  writeln('Массив А:');
  for i:=1 to n do
    begin
      a[i]:=random(101)-50;
      write(a[i],' ');
    end;
  writeln();
  writeln('Массив В:');
  for j:=1 to m do
    begin
      b[j]:=random(101)-50;
      write(b[j],' ');
    end;
  writeln();
{сливаем два массива в один}
  for i:=1 to n do c[i]:=a[i];
  for j:=1 to m do c[j+n]:=b[j];
{сортируем по убыванию}
  k:=n+m;
  for i:=1 to k-1 do
    begin
      t:=i;
      max:=c[i];
      for j:=i+1 to k do
        if c[j]>max then
          begin
            max:=c[j];
            t:=j;
          end;
      c[t]:=c[i];
      c[i]:=max;
    end;
{выводим результат}
  writeln('Массив C:');
  for i:=1 to k do
    write(c[i]:4);
  readln;
end.

Ответить

Другие вопросы из категории

Написать программу на языке Паскаль для вычисления значений функции y (см. для своего варианта) на интервале [a,b] с шагом h. Значения a,b и h ввести с

клавиатуры. На экран вывести результат вычислений в виде таблицы. 1 Блок-схема алгоритма программы, выполненная с использованием графических средств редактора WORD; 2 Текст программы; 3 Результаты выполнения (копия экрана). (3x+2)^2- sqrt3x/(3x)^2 a 5;b 7; h 0,1

Pascal (Паскаль). Очень прошу помощи

Составить программу сортировки массива методом пузырька НО не использовать for
Только через repeat + использовать flag
Всего в программе должно быть 3 переменных:

Читайте также

Помогите пожалуйста, очень нужно!

Программирование
Решить квадратное уравнения вида ax^2 + bx + c = 0
К решению математическая модель:
Дано:
Нужно:
Связь:
При:

привет всем)помогите пож-та с задачей. Найти и распечатать строку заданной целочисленной матрицы размером 10х10, в которой длина максимальной серии

минимальна. (Серия-последовательность одинаковых элементов. Длина серии-количество одинаковых элементов) .(паскаль) очень очень нужно))) заранее спасибо))

Составить программу на языке Паскаль.Определите, кратно ли трем значение целочисленной переменной X. Если это имеет место, то выведите на печать

значение Х с соответствующим сообщением, если нет, то выведите на печать "нет".
Помогите, пожалуйста, очень нужно)



Вы находитесь на странице вопроса "Помогите пожалуйста,очень нужно. Заранее спасибо. Смотрите приложение. Задания по ту Турбо Паскаль.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.