Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Здравствуйте) помогите составить задачи по паскалю)

10-11 класс

задачи на такую тему: Составление, ввод, трансляция и
исполнение программ, реализующих
циклические алгоритмы и типовые
операции с одномерными массивами

Chuprova1998 08 авг. 2013 г., 0:04:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KristushaYU
08 авг. 2013 г., 0:41:08 (10 лет назад)

var
  j, n: integer;
  x: array[0..100] of double;

begin
  Write('Введите значение n: ');
  Readln(n);
  { Необходимо задать значения x[0], x[1] }
  x[0] := 1; x[1] := 1;
  for j := 2 to n do
  begin
    x[j] := sqr(cos(x[j - 1])) + sqrt(abs(ln(x[j - 2])));
    x[j - 2] := x[j - 1]; x[j - 1] := x[j];
    Write(x[j]:0:5, ' ')
  end
end.

Тестовое решение:

Введите значение n: 10
0.29193 2.02679 1.03442 0.44511 1.71431 0.75463 1.06134 0.48185 1.63972

const
  n = 100;

var
  k, m: integer;
  b: array[1..n] of real;
  s: real;

begin
  Write('Введите значение m: ');
  Readln(m);
  Randomize;
  s := 0;
  for k := 1 to m do
  begin
    b[k] := 50 * Random - 25;
    s := s + cos(b[k]) + ln(abs(b[k]))
  end;
  s := s + 2.4e-2;
  Writeln(s)
end.

Тестовое решение:

Введите значение m: 10
14.8684009707635

const
  n = 10;

var
  x: array[1..n] of integer;
  s, i: integer;

begin
  s := 0;
  Randomize;
  Write('Элементы массива: ');
  for i := 1 to n do
  begin
    x[i] := Random(101) - 50;
    Write(x[i]:4);
    s := s + x[i]
  end;
  Writeln;
  Writeln('Среднее=', s / n)
end.

Тестовое решение:

Элементы массива:    5 -43  50  38   9  32   4 -12   6  -2
Среднее=8.7







Ответить

Другие вопросы из категории

1) Скорость передачи данных через ADSL-соединение равна 1024000 бит/c. Передача файла через данное соединение заняла 5 секунд. Определите размер файла

в килобайтах.

2) Скорость передачи данных через ADSL-соединение равна 256000 бит/c. Передача файла через это соединение заняла 2 минуты. Определите размер файла в килобайтах.

3) Сколько секунд потребуется обычному модему, передающему сообщения со скоростью 28800 бит/с, чтобы передать цветное растровое изображение размером 640х480 пикселей, при условии, что цвет каждого пикселя кодируется тремя байтами?

4) Скорость передачи данных через модемное соединение равна 51 200 бит/с. Передача текстового файла через это соединение заняла 10 с. Определите, сколько символов содержал переданный текст, если известно, что он был представлен в 16-битной кодировке Unicode.

5) Скорость передачи данных через ADSL-соединение равна 128000 бит/с. Передача текстового файла через это соединение заняла 1 минуту. Определите, сколько символов содержал переданный текст, если известно, что он был представлен в 16-битной кодировке Unicode.

6) Информационное сообщение объемом 2.5 Кбайт передается со скоростью 2560 бит/мин. За сколько минут будет передано данное сообщение?

Составьте пожалуйста программу!!!! Даны целые положительные числа A, B, C. На прямоугольнике размера A x B размещено максимально возможное количество

квадратов со стороной C (без наложений). Найти количество квадратов, размещенных на прямоугольнике, а также площадь незанятой части прямоугольника.

Помогите с двоичной системой

Читайте также

Помогите решить задачи по паскалю:

1. модифицируйте предыдущий пример, так чтобы программа определяла максимальный и минимальный элемент массива
2. Напишите программу, которая бы определяла среднее арифметическое значение элементов массива (вещественная величина типа real)
Начало:
var a: array[1..10] of integer;
i: integer;
begin
а как дальше?

Предыдущий пример:
var a: array[1..10] of integer;
i: integer;
begin
randomize;
for i:=1 to 10 do
begina[i]:=random(40)-20;
end;
for i:=1write(a[i]:4);
end.

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:



Вы находитесь на странице вопроса "Здравствуйте) помогите составить задачи по паскалю)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.