Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найдите сумму нечётных отрицательных чисел на промежутке [-36;36] делящихся на 7

5-9 класс

(составить программу )

Dasasasa2003 20 мая 2014 г., 10:27:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastyragozina
20 мая 2014 г., 13:12:39 (9 лет назад)

program p1;
const n=10;
var a: array [1..n] of integer;
s,i: integer;
begin
randomize;
for i:= 1 to n do
begin
a[i]:= random (73)-36
;write (a[i]:3);
end;
s:=0;
for i:=1 to n do
begin
if (a[i] mod 2<>0) and (a[i] mod 7=0) then
begin
s:=s+a[i];
end;
end;
writeln;
writeln ('сумма=',s);
end.
единственное не учел момент когда таких числе нет, можете дописать

Ответить

Другие вопросы из категории

Рассчитайте объём памяти, необходимый для кодирования

рисунка, построенного при графическом разрешениимонитора800х600 с палитрой 32 цвета.


Какой объем видеопамяти необходим для хранения четырех страниц изображения при условии, что разрешающая способность дисплея 640х480 точек, а глубина цвета 32?

Читайте также

Найдите сумму всех натуральных чисел на промежутке от 1 до n.

Число n вводится на клавиатуре.Составьте на Паскале с циклом WHILE

Найдите сумму всех натуральных чисел на промежутке от 1 до n.

Число n вводится на клавиатуре.Составьте на Паскале с циклом WHILE

Найдите сумму всех натуральных чисел на промежутке от 1 до n.

Число n вводится на клавиатуре.Составьте на Паскале с циклом WHILE

1)среди 15 чисел найдите сумму всех положительных чисел

2) среди 15 чисел найдите количество всех чисел которые являются не отрицательными

Составьте программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2;3] и подсчитывает сумму

отрицательных чисел. Вывод в столбец с двумя десятичными знаками. Только Паскаль ABC!



Вы находитесь на странице вопроса "найдите сумму нечётных отрицательных чисел на промежутке [-36;36] делящихся на 7", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.