Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дано описание массива mas: array [-2..12] of integer.Сколько элементов содержит данный массив?

10-11 класс

Anutka1994 31 авг. 2014 г., 12:43:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Identifikazija
31 авг. 2014 г., 13:42:46 (9 лет назад)

Массив содержит 12-(-2)+1=15 элементов.

Ответить

Другие вопросы из категории

Кот Матроскин и пёс Шарик нашли клад, который состоял из 5 одинаковых монт. В коробке, в которой лежали монеты, друзья обнаружили записку: "При

помощи чашечных весов без гирь найдите среди этих 5 монет одну золотую и купите почтальону Печкину велосипед. Сделайте это при помощи двух взвешиваний. Золотыя монета более тяжёлая". Дядя Фёдор помог своим друзьям справится с этим заданием. Как он действовал? Впишите действия Дяди Фёдора в блок схему.Плиз помогите!((Только нужна блок-схема

Необходимо составить программу с использованием рекурсии Замечание: под инвертированием понимают перестановку первого и последнего

элементов этой части, второго и предпоследнего и т.д.


Инвертировать часть массива, расположенную между самым левым минимальным в первой половине массива и самым правым максимальным во второй половине массива.

ТЕРМІНОВО!!! ДО ЗАВТРА!!!

1. Тема: Обробка символьних рядків (даних типу String)
Завдання: Дано рядок символів, який складається з окремих слів, відокремлених інтервалом. Порахувати:
- кількість слів у рядку;
- кількість голосних букв у слові.

2. Тема: Обробка даних типу запис.
Завдання: скласти програму утворення даних типу запис у вигляді таблиці, з подальшим записом її в текстовий файл для створення довідкової інформації. У програмі передбачити створення слідуючих підпрограм-процедур:
2.1. формування 5-7 елементів масиву типу запис з полями, вказаними у індивідуальному завданні, з послідуючим їх записом у текстовий файл.
2.2. виведення на екран елементів масиву записів у відповідності з індивідуальним завданням.
Індивідуальне завдання: Список робітників підприємства: табельний номер, ПІБ, посада, дата прийняття на роботу, оклад. Роздрукувати дані про техніка, отримавшого найбільшу зарплатню.

Писати на Паскалі.
Тому, хто відповість правильно натисну "Краща відповідь і подякую на сторінці". Спам не писати заради балів.

Читайте также

дано описание массива: const m=3; n=11;

var mas: array [m..n] of integer
напишите оператор присваивания, который в элементе массива, находящийся ровно в центре массива, заносит значение произведения первого и второго элемента

Uses crt;

type mas=array[1..98] of integer;
var A,F,Q,C:mas;
i,s:integer;
begin
clrscr;
writeln('Массив первый:');
for i:=1 to 98 do
begin
A[i]:=random(100)-2;
write(A[i]:4);
end;
writeln;
writeln('Массив второй :');
for i:=1 to 98 do
begin
F[i]:=random(100)-2;
write(F[i]:4);
end;
writeln;
writeln('Массив третий :');
for i:=1 to 8 do
begin
Q[i]:=random(60)-52;
write(Q[i]:4);
end;
writeln;
writeln('Массив четвертый:');
for i:=1 to 8 do
begin
C[i]:=(sqrt(A[i])+sqrt(F[i]))/2+sin(A[i]*F[i])+(sqrt(Q[i])+sqrt(F[i]))/2+sin(Q[i]*F[i])+(sqrt(A[i])+sqrt(Q[i]))/2+sin(A[i]*Q[i]);
write(C[i]:4);
end;
writeln;
end.

Даны массивы A98), F98),Q(8). Сформировать массивы С(8), каждый элемент которого вычисляется по формулеC[i]:=(sqrt(A[i])+sqrt(F[i]))/2+sin(A[i]*F[i])+(sqrt(Q[i])+sqrt(F[i]))/2+sin(Q[i]*F[i])+(sqrt(A[i])+sqrt(Q[i]))/2+sin(A[i]*Q[i]);

Вычисление по формуле (x^2+y^2)/2+sin(X*Y) оформить в виде подпрограммы.

program klass; type ocenki=record name:string[15]; marks: array [1..5] of integer; end; var a,k,i:integer;

c:array [1..5] of ocenki;

begin k:=0;

For i:=1 to 5 do

With c[i] do

begin

write('vvedite name'); readln(name);

write('vvedine marks');

for i:=1 to 5 do read(marks[i]);

a:=i;

if c[a].marks < 2 (вот здесь выдает что операнды имеют неприводимые типы) then k:=k+1; writeln(k);

end;

end.

(Подскажите пожалуйста где допустила ошибку)

2. Сколько элементов в каждом из следующих массивов:

• var mb: array [2..20] of integer;
• type myarray1= array [0..8] of integer;
myarray2= array [-5..5] of integer;
var aa: myarray1;
bb: myarray2;

Много баллов(78) за блок-схему...завтра курсовую сдавать :( программа на паскале uses crt; type

mas=array [1..100] of integer;

var

b:mas;

p,i,n:integer;

procedure vvod (x:mas;k:integer);

var i,p:integer;

begin

for i:=1 to n do begin

write('Vvedite chislo: ');

readln(x[i]);

end;

for i:=1 to n do

write(x[i]:3);

for i:=n downto 1 do

if x[i]<0 then

p:=i;

writeln;

write('= ',x[p-1]);

writeln;

readln;

end;

begin

clrscr;

write('Vvedite kol-vo chisel: ');

readln((n));

vvod (b,n);

readln;

end.



Вы находитесь на странице вопроса "дано описание массива mas: array [-2..12] of integer.Сколько элементов содержит данный массив?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.