Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста задачу сделать в паскале. Составьте программу, которая удаляет из слова X те буквы, которые встречаются в слове Z. Слова X и

5-9 класс

Z вводятся с клавиатуры.

Амёнкаоаоал 04 апр. 2017 г., 21:22:25 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ычв
04 апр. 2017 г., 22:37:21 (7 лет назад)

var
x,z:string;
i:integer;
ar:array['а'..'я'] of boolean;
begin
readln(x);
readln(z);

for i:=1 to Length(z) do
  ar[z[i]]:=true;
  for i:=Length(x) downto 1 do
    if (ar[x[i]] = true) then delete(x,i-1,1);   
writeln(x);
end.

Не забудь отметить лучший ответ ;-)

Ответить

Другие вопросы из категории

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА

ОЧЕНЬ СРОЧНО
задача за 8 класс , нужно сделать по типу "фри паскаля "
Составьте программу, которая будет запрашивать стоимость за покупку ,сумму денег ,внесенную покупателем в кассу ,далее определяет причитывающеюся ему сдачу (если денег внесено больше ,печатает "Спасибо"(если сдачи не требуется,или выдает сообщение о недостаточности внесенной суммы

помогите пожалуйста!!!задание по информатике(паскаль)

Составить программу описания двух переменных чисел:трех действительн., трех целых, трех постоянных ,целые(2 чиловые ,1 символьная)
на уроке успели только 1 пример сделать:
Program _ Zadacha _1 ;
const_ s1=3
pi=3.14;
var_c2,c1:integer;
b2:real;
begin
end.

Помогите, пожалуйста, решить самостоятельную:1.Составьте блок-схему и программу вычисления значения функции

(картинка дана ниже)

2.Составьте программу, определяющую, является ли данное число делителем числа 3.

3.Составьте программу, заменяющую меньшее из двух данных чисел суммой, а большее - произведением этих чисел.

Заранее спасибо.

ПОМОГИТЕ ПОЖАЛУЙСТА!

На языке паскаль составить программу , выводящую на экран наименьшее из трех чисел.Программа должна выводить на экран результат в виде:Наименьшее из данных трех чисел=Значение.

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!



Вы находитесь на странице вопроса "Помогите пожалуйста задачу сделать в паскале. Составьте программу, которая удаляет из слова X те буквы, которые встречаются в слове Z. Слова X и", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.