Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Что будет выведено после выполнения следующего фрагмента алгоритма, представленного в виде блок-схемы, если q=15. В ответе укажите только число.

5-9 класс

Хороший4еловек 01 сент. 2013 г., 6:17:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
16072002eva
01 сент. 2013 г., 8:25:34 (10 лет назад)

var q,s,i,k:integer;
   beginq:=15; s:=0; i:=1;
while s<q do             begin              s:=s+i; i:=i+1;             end;k:=i-2; writeln('k=',k);    end.

Если правильно сделал, то к=4.

Ответить

Другие вопросы из категории

Составить программы в Turbo Pascal. 1)Дано три точки A,B,C на числовой оси.Найти длинну отрезка AC и BC и их сумму. 2)Задано четыре целых числа

a,b,c,d.Выяснить произведение этих чисел больше 300? 3)Дано целое число ,если оно положительное,то прибавить к нему 1,а если отрицательное.то отнять от него 2.Вывести полученое число.

С клавиатуры вводятся 100 чисел. Найти сумму тех из них, которые больше 10.

На языке Паскаль. Очень нужно!

Читайте также

нужна помощь, ребята!

определить значение переменной S после выполнения следующего фрагмента алгоритма, представленного в виде блок-схемы, если а=692.
Начало:
1) ввод а,
2) S:=0
3) S:=s+a mod 10
4) a:=a div 10
5) a=0, если нет, то вернуться к 3 действию если да то вывод S
6) конец

определить значение переменной S после выполнения следующего фрагмента алгоритма, представленного в виде блок-схемы, если а=692.

Начало:
1) ввод а,
2) S:=0
3) S:=s+a mod 10
4) a:=a div 10
5) a=0, если нет, то вернуться к 3 действию если да то вывод S
6) конец



Вы находитесь на странице вопроса "Что будет выведено после выполнения следующего фрагмента алгоритма, представленного в виде блок-схемы, если q=15. В ответе укажите только число.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.