Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дан массив из n чисел найти сумму тех чисел у которых нечетный индехс и числа кратны 5 или 3

5-9 класс

My3bi4ka 11 мая 2014 г., 15:28:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
54835873
11 мая 2014 г., 16:56:13 (10 лет назад)

var a:array[1..100000] of integer;
s,i,n:integer;
begin
readln(n);
for i:=1 to n do begin
read(a[i]);
if (i mod 2 <> 0) and ((a[i] mod 5 = 0) or (a[i] mod 3 = 0)) then s+=a[i];
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста!:)

A10=114 B10=77

Что лишнее: подстаканник,подлокотник,подорожник,подснежник озимь,цитадель,фланель,панцирь брюки,хлопоты,дверцы,вилы

дебри,прения,игры,шахматы

ножницы,дрожжи щипцы башмаки

горе нагорный горевать горемыка

1. (Char). Пользователь вводит текст, признаком конца которого явля­ется точка. Напечатать true,

если буква «а» встречается чаще, чем буква «в», и напечатать false

Читайте также

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.



Вы находитесь на странице вопроса "дан массив из n чисел найти сумму тех чисел у которых нечетный индехс и числа кратны 5 или 3", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.