Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

СРОЧНО!!! ПРОСТО НАПИСАТЬ РЕШЕНИЕ!!!! Как в программе Free Pascal.

5-9 класс

Заданы 3 действительных числа. Посчитать количество целых чисел. Использовать функцию int(a)-целая часть числа а.

Familysadakat 21 февр. 2017 г., 11:22:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lesidg
21 февр. 2017 г., 14:21:51 (7 лет назад)

Вот верное решение, но как мне кажется немножко кривое))) можно было красивее сделать:)

var  a, b, c, d, e, f, sum: real;
begin  readln(a, b, c);  d := int(a);  e := int(b);  f := int(c);  sum := 0;  if a = d then sum := sum + a;  if b = e then sum := sum + b;  if c = f then sum := sum + c;  writeln(sum);end.

+ 0 -
Natasha06032001
21 февр. 2017 г., 15:48:43 (7 лет назад)

попробую

+ 0 -
умняшка1очеровашка
21 февр. 2017 г., 18:15:03 (7 лет назад)

жду)

+ 0 -
Сэв
21 февр. 2017 г., 19:40:45 (7 лет назад)

числа с клавиатуры вводятся?

+ 0 -
Elienle
21 февр. 2017 г., 22:32:43 (7 лет назад)

будем считать, что да

+ 0 -
Nastygggg
22 февр. 2017 г., 0:39:45 (7 лет назад)

огромное спасибо за решение))

Ответить

Другие вопросы из категории

1)Что такое информационный кризис?

2)Взаимозависимость компьютеризации общества и развития информационного кризиса.
3)Почему затягивают сети?
4)Что выбирает новое поколение:письмо ручкой или движение мышкой?
5)Положительное и отрицательное влияние информатизации.

Выберите правильный ответ.

а) Если вы собираетесь провести выходной день на природе, то своевременной информацией для вас будет:
1) сведения о погоде в такой же день прошлого года;
2) прогноз погоды на выходной день.
б) Волга впадает в Каспийское море - это:
1) достоверная информация;
2) недостоверная информация.
в) Слухи, вымыслы, непроверенные гипотезы - это;
1) достоверная информация;
2) недостоверная информация.
г) Информация о том, как с помощью подручных средств добыть огонь, будет для вас наиболее полезной;
1) если вы попадёте на необитаемый остров;
2) в нашей повседневной жизни.
д) О правилах дорожного движения каждый водитель автомобиля;
1) должен обладать полной информацией;
2) может иметь неполную информацию.
е) Об устройстве двигателя каждый водитель автомобиля;
1) должен обладать полной информацией;
2) может иметь неполную информацию.

Сколько байтов в следующем сообщении (кодировка АSCII)?

Сегодня очень холодно…

Помогите решить задачу! прошу вас!

Читайте также

1.Какие типы программ входят в системное программное обеспечение компьютера?

2. Каким образом можно перезагрузить компьютер?
3.Какие служебные программы имеются в составе Windows и для чего они предназначены?
4. Какие основные типы программного обеспечения?
5. В чем состоит основное различие между операционной системой и прикладными программами?

помогите составить программу FREE PASCAL

После каждой двойки вставить число 100

Помогите СРОЧНО,нужно написать какие программы в компьюторе мне нра...

Какими программами я люблю пользоваться.....
Например: Я люблю слушать музыку в проигрователе AIMP3.....
Надо буквально 5-6 предложений....И программ примерно 3-4.....
ПОМОГИТЕ.....Зарание БОЛЬШОЕ спасибо*)

Как в программе кумир написать : 07.06.2000 со смещениями на вектор?

И как там еще написать:1 2 3 4 5 6 7 со смещениями в точку?
помогите пожалуйста!!!

5-9 класс информатика ответов нет
Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).



Вы находитесь на странице вопроса "СРОЧНО!!! ПРОСТО НАПИСАТЬ РЕШЕНИЕ!!!! Как в программе Free Pascal.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.