Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Сделайте плиз алгоритм"!!!!!

5-9 класс

Ekaterina981108 24 февр. 2017 г., 16:27:43 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kriper471
24 февр. 2017 г., 17:05:45 (7 лет назад)

program p1;
var a:integer;
Begin
writeln('введите число');
readln(a);
if (a mod 10) =0 then writeln ('число делится на 10') else writeln ('число не делится на 10');
end.
Вот программа,на картинке и есть алгоритм,вроде.Если что можно программу в алгоритм переделать просто записав условие в ромб,а 'да' 'нет' в ответвлении.

+ 0 -
ПриКолИст222
24 февр. 2017 г., 18:54:00 (7 лет назад)

неправильно

+ 0 -
73antonova
24 февр. 2017 г., 20:19:28 (7 лет назад)

все тут правильно, mod это и есть остаток от числа и если он равен нулю при делении на 10 значит число делится на 10 без остатка, алгоритм так будет выглядеть: начало=>Х=> (X mod 10 = 0)=>(над стрелкой да) число делится на 10;потом еще одна стрелка и над ней 'нет' => число не делится на 10;конец.

Ответить

Другие вопросы из категории

СРОЧНО!!! ПРОСТО НАПИСАТЬ РЕШЕНИЕ!!!! Как в программе Free Pascal.

Заданы 3 действительных числа. Посчитать количество целых чисел. Использовать функцию int(a)-целая часть числа а.

1)Что такое информационный кризис?

2)Взаимозависимость компьютеризации общества и развития информационного кризиса.
3)Почему затягивают сети?
4)Что выбирает новое поколение:письмо ручкой или движение мышкой?
5)Положительное и отрицательное влияние информатизации.

Выберите правильный ответ.

а) Если вы собираетесь провести выходной день на природе, то своевременной информацией для вас будет:
1) сведения о погоде в такой же день прошлого года;
2) прогноз погоды на выходной день.
б) Волга впадает в Каспийское море - это:
1) достоверная информация;
2) недостоверная информация.
в) Слухи, вымыслы, непроверенные гипотезы - это;
1) достоверная информация;
2) недостоверная информация.
г) Информация о том, как с помощью подручных средств добыть огонь, будет для вас наиболее полезной;
1) если вы попадёте на необитаемый остров;
2) в нашей повседневной жизни.
д) О правилах дорожного движения каждый водитель автомобиля;
1) должен обладать полной информацией;
2) может иметь неполную информацию.
е) Об устройстве двигателя каждый водитель автомобиля;
1) должен обладать полной информацией;
2) может иметь неполную информацию.

Сколько байтов в следующем сообщении (кодировка АSCII)?

Сегодня очень холодно…

Помогите решить задачу! прошу вас!

Читайте также

написать команды для обмена значениями 2 переменных a и b не используя дополнительную переменную определить сколько полных часов(h) и полных

минут(m)прошло с начала суток до того момента (в первой половине дня) когда часовая стрелка повернется на (f) градусов (от 0 до 360)

сделать ввиде алгоритма

ПОМОГИТЕ, НАПИСАТЬ КОРОТКИЙ АЛГОРИТМ, ЧТОБЫ РОБОТ СДЕЛАЛ РИСУНОК КАК В ЗАДАНИИ №2

СДЕЛАЙТЕ, ПОЖАЛУЙСТА, ТОЛЬКО ВТОРОЙ НОМЕР!!!

ПОМОГИТЕ! ПОЖАЛУЙСТА. АЛГОРИТМ.

10:2+5=10, (40-20)*6:3 =40 сделать алгоритм, плиииз

1)Дан фрагмент линейного алгоритма.

а:=8

b:=6+3*а

а:=b/3*а

Чему равно значение переменной а после его исполнения?


Ваш ответ:

2)Исполните следующий фрагмент линейного алгоритм для а = х и b = y.

а:=а+b

b:=b-a

а:=а+b

b:=-b

Какие значения присвоены переменным a и b?

а)-у, х
б)y, х
в)х, у
г)х+у, х-у

3)Определите значение целочисленных переменных х и у после выполнения фрагмента программы.

х:=11

у:=5

t:=y

у:=х mod у

x:=t

y:=y+2*t

а)х = 10, у = 5
б)х = 5, у = 11
в)x = 11, y = 5
г)х = 5, у = 10

4)Среди четырёх монет есть одна фальшивая. Неизвестно, легче она или тяжелее настоящей. Какое минимальное количество взвешиваний необходимо сделать на весах с двумя чашками без гирь, чтобы определить фальшивую монету?

а)4
б)2
в)5
с)3



Вы находитесь на странице вопроса "Сделайте плиз алгоритм"!!!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.