Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Выполнить задачу на паскале (можно скрин с экрана) заполнить массив из 16 элементов случайными числами в интервале [-10..10] и найти в нем

5-9 класс

максимальный элемент и его номер. Отмечу как лучшее!

HaCTeHka13 04 авг. 2013 г., 20:16:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
кроликяна
04 авг. 2013 г., 22:59:07 (10 лет назад)

program maxelem;
const n=16;
var i,max:integer;
a:array[1..n] of integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(-10,10);
write(a[i],' ');
end;
writeln();
max:=a[1];
for i:=2 to n do
if a[i]>max then
max:=a[i];
writeln(max);
end.

+ 0 -
Natalia1231
05 авг. 2013 г., 1:04:35 (10 лет назад)

uses crt;
var i, n, a :integer;
    s :array [1..16] of integer;
begin
   clrscr;      // так для красоты
   a:=-10;     // пусть максимальный элемент равен минимальному, который возможен
   n:=1;       // и он стоит под номером 1
   for i:=1 to 16 do
   begin
      s[i]:=random(21)-10;  // заполняем массив
      writeln ('s[', i, '] =', s[i]); // показываем его, для достоверности
      if s[i]>=a then // проверяем больше ли он максимального
      begin
         a:=s[i]; // если условие выполнилось, то приравниваем новое максимальное значение
         n:=i;   // и его номер
      end;
   end;
   write ('Максимальный элемент = ', a, ', который стоит под номером = ', n); // и выводим собственно ответ
end.

Ответить

Другие вопросы из категории

Световое табло состоит из лампочек. Каждая лампочка может находится в одном из трех состояний(включено, выключено или мегает). Какое наименьшее

количество лампочек должно находится на табло, чтобы с его помощью можно было передать 18 различных сигналов?

Читайте также

помогите пожалуйста составить программу

Заполнить массив из 500 элементов случайными числами в интервале [0..100]. Отсортировать его по возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» . Вывести на экран число перестановок элементов массива в том и в другом случае. Массив выводить на экран не нужно.

Люди очень срочно решите пожалуйста задачу на Паскале:

их 4 штуки!
1.дан массив тз N элементов. Есть ли в нем чётные элементы, которые кратны заданному числу K.
2. Дан массив из Nэлементов. Посчитать, сколько элементов массива равных минемальному.
3. Сформировать массив из Nэлементов: 10 12 16 22 30 40.
4. Дан массив из Nэлементов. Перемножить минемальные элементы на 2.
Heeelp!

Пожалуйста помогите, задачи в Паскале:

1)Заполнить массив случайными числами от -100 до +100
и распечатать на экране только отрицательные числа
2)Дан массив из 20 элементов числа от -50 до +50
а)Каждый элемент больше 10 заменить на его квадратный корень
б)Все элементы с четными номерами заменить на их абсолютную величину(модуль)
в)Ко всем отрицательным элементам прибавить 5 , а к остальным первый элемент массива

сформулируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлен по следующему правилу: первый

равен 500; второй равен целой части квадратного корня из предыдущего элемента; третий равен целой части от деления текущего индекса на три части (если она равна нулю,то соответствующий элемент массива делать равным 1)



Вы находитесь на странице вопроса "Выполнить задачу на паскале (можно скрин с экрана) заполнить массив из 16 элементов случайными числами в интервале [-10..10] и найти в нем", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.