Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

На паскале нужно сделать. с клавиатуры вводится n элементов массива целых чисел вывести количество чисел которые попадаются в диапозоне от 10 до 30

10-11 класс

Aidina30981 08 сент. 2013 г., 14:12:00 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Abu1
08 сент. 2013 г., 15:18:11 (10 лет назад)

Program p1;
Uses crt;
Var A: array [1..10] of integer;
i,k: integer;
Begin clrscr;
Writeln ('Введите элементы массива');
for i:=1 to 10 do
read (a[i]);
k:=0;
for i:=1 to 10 do
begin
if (a[i]>10) and (a[i]<30) then
k:=k+1;
end;
writeln ('Количество чисел в диапазоне (10;30) =',k);
Readln;
readkey;
end.

Ответить

Другие вопросы из категории

уровень потенциала металла
На некотором заводе существует автоматизированный цех по производству роботов. За двое суток одна пара роботов собирает из деталей ещё одного робота, ко

торый затем включается в процесс сборки следующих роботов. В сборке участвуют только пары роботов (если у робота нет пары - он простаивает). Рабочий цикл составляет 10 суток; по окончании десятого дня из цеха на склад увозят всех произведенных роботов; в цехе остается число роботов, необходимых для воспроизводства того же количества в следующем десятидневном цикле. Детали для производства роботов подвозят без перебоя. Какое минимальное число роботов надо оставлять в цехе по окончании цикла, чтобы в каждом рабочем цикле производилось не менее 24 роботов?

Читайте также

1)заполнить массив из 15 элементов числами из интервала от -10 до 10 вывести в строчку и повторно вывести в строчку,заменив все четные элементы на число

100.
2) Заполнить массив целыми положительными и отрицательными числами из интервала [-10;10] и вывести его в строчку. Поменять знаки элементов массива на противоположные и повторно вывести массив на экран в строчку.
Пожалуйста,помогите,очень срочно!!!

№1.Составьте программу,выбирающую из всех вводимых в ЭВМ чисел только те, которые входят в интервал от 1 до 5.Ввод производится до тех пор пока сумма

всех введенных данных чисел не будет равна 177. №2. Определите диаметр круга, радиус, площадь, если известна длина окружности L. №3.Даны два действительных числа А, В. Найти наибольшее из них и выяснить четное оно или нет.

1) найди последний элемент массива меньше заданного числа

2) найди наибольший элемент одномерного массива
3) найти произведение элементов массива целых чисел от 1 до N, которые кратны 9
4) найти сумму чисел, имеющие нечетные номера
5) найти сумму наименьшего и наибольшего элементов массива
И ЭТО ВСЕ В ПАСКАЛЕ!!!!!!!



Вы находитесь на странице вопроса "На паскале нужно сделать. с клавиатуры вводится n элементов массива целых чисел вывести количество чисел которые попадаются в диапозоне от 10 до 30", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.