Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Как найти сумму элементов 1 строки?

10-11 класс

program sbb;

uses crt;

var

i,j,s:integer;

a:array[1..5,1..10] of integer;

begin

for i:=1 to 5 do

begin

for j:=1 to 10 do

begin

random(50);

a[i,j]:=random(50);

write(' ');

write(a[i,j]);

end;

writeln

end;

Denisbaturin 28 авг. 2014 г., 21:19:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Amateurmiller
28 авг. 2014 г., 22:42:31 (9 лет назад)

Uses crt;
Var
 i,j,s:integer;
 a:array[1..5,1..10] of integer;
Begin   
   for i:=1 to 5 do
        begin
           for j:=1 to 10 do
             begin
               random(50);               
               a[i,j]:=random(50);               
               write(' ');               
               write(a[i,j]);                 
               if i=1 then begin             
                              s:=s+a[i,j];
                              end;     
                        end;         
            writeln
   end;
  writeln(s);
end.

Так же можно сделать чтобы искалась сумма каждой строки, например вот код на скрине... 

Ответить

Другие вопросы из категории

1. Дано натуральное число n. Переставить его цифры так, чтобы образовалось максимальное число, записанное теми же цифрами.

2. Найти все двузначные числа, сумма квадратов которых делится на 17.

Всё это нужно сделать в программе Паскаль, но КАК?!

500 !!!! Доклад на тему:"Облачные-

технологии и их применение на практике" 11 класс (пожалуйста, хорошая работа нужна)

создать блок-схему к процедуре

Читайте также

Всем Привет! Люди добрые помогите решением. Первую задачу отправил на проверку Спасибо!!! Сейчас вторая. В матрице A(m x m) найти сумму элементов

четных столбцов. Если эта сумма положительна, то все элементы нечетных строк возвести в квадрат. В противном случае ко всем элементам побочной диагонали прибавить число 2.

10-11 класс информатика ответов нет
1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

составить программу 1)найти сумму всех элементов массива (1до10) random. 2)сформировать массив из положительных и отрицательных элементов

от -10 до 30.найти кол-во положит и отриц элементов.найти сумму положит и произведение отриц.

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.



Вы находитесь на странице вопроса "Как найти сумму элементов 1 строки?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.