Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух

10-11 класс

последних цифр заданного числа; 3) число, образованное перестановкой второй и четвёртой цифр заданного числа.

Natagen26601 01 марта 2015 г., 11:28:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dddddddddddddddd
01 марта 2015 г., 12:07:00 (9 лет назад)

program znaka4;
var a:integer;
begin
repeat
readln(a);
until (a>1000) and (a<10000);
writeln('1 zadanie= ',a mod 10,a div 10 mod 10,a div 100 mod 10,a div 1000);
writeln('2 zadanie= ',a div 100 mod 10,a div 1000,a mod 10,a div 10 mod 10);
writeln('3 zadanie= ',a div 1000,a mod 10,a div 10 mod 10,a div 100 mod 10);
end.

Ответить

Другие вопросы из категории

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

5. Дано трехзначное число. Кратна ли сумма его цифр семи?

8. Дано три натуральных числа x, y, z. Вычислить количество чисел меньших 50.

Дана матрица размерностью nxn найти

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали

Integer8◦

. Дано двузначное число. Вывести число, полученное при переста-
новке цифр исходного числа.



Вы находитесь на странице вопроса "Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.