Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите решить такое задание

10-11 класс

Дано натуральное число N. Вычислить y=2*4*6*...(2n). Вводится число n. В цикле типа пока шаг равен 2, перебираются все числа от 2 до 2n, шаг равен 2, все числа перемножаются)

Xamidovaxava 15 апр. 2014 г., 22:36:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Нашиуроки
16 апр. 2014 г., 1:17:07 (10 лет назад)

uses crt;
var i,s,n:integer;
begin
s:=1;n:=0;
while (n<=0) do begin
writeln ('Введите неотрицательное число');
read (n);
end;
n:=n*2;
writeln ('Считаю все числа от 2 до ',n);
write ('1');
for i:=1 to n do begin
i:=i+1;
write ('*',i);
s:=s*i;
end;
writeln ;
writeln ('Произведение = ',s);
end.

P.s. Программа написана на языке Pascal ABC. По всем вопросам обращаться в комментарии !

Ответить

Другие вопросы из категории

Помогите пожалуйста! Какую операцию можно выполнить только над замкнутым объектом? а) преобразовать в кривую Безье; б) выполнить

обводку;

в) задать контур;

г) выполнить заливку;

д) изменить число узлов.

Даны два действительных числа x и y. Вычислить их сумму,

разность, произведение и частное. напишите программу в паскаль

Устройство на базе ЭВМ, объединяющее два разнородных сетевых сегмента и предназначенное для обработки потока данных, проходящих между ними

1) коммутатор (switch)

2) шлюз

3) маршрутизатор (router)

4) хаб (hub)

5) все ответы верны

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Здравствуйте, прошу помогите решить такое вот чудо.

Решить вроде бы нужно найти что за число вместо x.
Кто знает как правильнее прошу вашей помощи.
Чтобы просмотреть фото, кликните на него.

Объясните по подробнее как решать такие задания 1)Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1 2) 2 3) 3 4) 4

2)Для какого имени истинно высказывание:

¬ (Первая буква имени гласная → Четвертая буква имени согласная)?

1) ЕЛЕНА 2) ВАДИМ 3) АНТОН 4) ФЕДОР

помогите решить вот задание !
10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "помогите решить такое задание", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.