Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу для отыскания

5-9 класс

max(min(a,b), min(c,d)), не
используя сложные логические условия и вложенные ветвления. Числа a,b,c,d
- целые. Протестировать программу для следующих исходных данных:

Anfisa3103 23 февр. 2014 г., 20:28:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Daddd
23 февр. 2014 г., 22:53:31 (10 лет назад)

var a,b,c,d,m1,m2,max:integer;
begin
write('Введите a,b,c,d: ');
readln(a,b,c,d);
if a<b then m1:=a else m1:=b;
if c<d then m2:=c else m2:=d;
if m1<m2 then max:=m2 else max:=m1;
writeln('MAX=',max)
end.

Ответить

Другие вопросы из категории

Ученики 7 класса постоянно теряют учебники. Чтобы избавить учеников от этой скверной привычки, добрый учитель пронумеровал потерянные учебники и

соорудил из них пирамиду. Существует бесконечная пирамида книг, подписанных натуральными числамию Книги в ней располагаются по принципу - вначале по одной в ряду, затем по две книги в ряду, затем 4, затем 6 и тд. Числа на книгах идут последовательно от 1 до бесконечности. Требуется по номеру ряда N и положению в ряду К определить номер книги С находящейся там№ Если ученик определил где находится книга

Формат входных данных- Вводится число N, K; N<=20

Формат выходных данных. Требуется выдать число С

Для кодирования каждой буквы используется двузначное число. Известно что буква "е" закодироваано числом 20. Среди слов "полка", "после", "пока", "кол"

есть слова, кодируемые последовательностями цифр: 11321220, 11321022. Пользуясь данным кодом, закодируйте слово "колокол"

Читайте также

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

составить на Паскале: 1) программу для вычисления суммы ряда S=1+ 1/2+1/3+1/4+..+1/N. Число N вводится с клавиатуры. 2) одноклеточная

амеба каждые 3 часа делиться на 2 клетки. Определить, сколько амеб будет через 3,6,9,12 и 24 часа.

3) дано натуральное числоо N и действительное число Х. Вычислить сумму ряда sin(x)+sin(2x)+sin(3x)+...+sin(Nx).

4) написать программу для вычисления n-ой степени числа А.

помогите, пожалуйста)

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.



Вы находитесь на странице вопроса "Написать программу для отыскания", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.