Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

С помощь Паскаля решить задачи:

5-9 класс

1. Ввести с клавиатуры символьную строку и заменить в ней все буквы "а" на "б" и все буквы "б" на "а".( заглавные на заглавные и строчные на строчные буквы) пример: ааббАА, а после замены стало: ббааББ.
2.Ввести с клавиатуры символьную строку и определить сколько в ней слов. Пример: Вася пошел гулять.---- Найдено 3 слова.
3.Ввести с клавиатуры в одну строку фамилию, имя и отчество, разделив их пробелом. Вывести фамилию и инициалы. Пример: Пирожков Петр Васильевич, а стало : П.В . Пирожков.

Nata22b 07 авг. 2014 г., 3:32:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
макс20037834833
07 авг. 2014 г., 4:39:51 (9 лет назад)

1.
var s,s1:string;
i:integer;
begin
readln(s);
s1:=s;
for i:=1 to length(s1) do begin
if s1[i]='а' then s1[i]:='б' else
 if s1[i]='А' then s1[i]:='Б' else
  if s1[i]='б' then s1[i]:='а' else
   if s1[i]='Б' then s1[i]:='А';
end;
writeln(s1);end.

2.
var s,s1:string;
i,k:integer;
begin
readln(s);
s1:=s; i:=1; k:=1;
while pos(' ',s1)>0 do begin
delete(s1,1,pos(' ',s1));
k:=k+1;
end;
writeln(k);
end.

3.
var s,famil,s1,imya,otch:string;
i:integer;
begin
readln(s);
famil:=copy(s,1,pos(' ',s)-1);
delete(s,1,pos(' ',s));
imya:=copy(s,1,1);
delete(s,1,pos(' ',s));
otch:=copy(s,1,1);
s1:=concat(imya,'.',' ',otch,'.',' ',famil);
writeln(s1); end.





+ 0 -
Supertanuxa17
07 авг. 2014 г., 6:14:33 (9 лет назад)

Если вам нужно пояснение к программе, пишите в сообщения

+ 0 -
Dan4ik714
07 авг. 2014 г., 7:08:02 (9 лет назад)

10 минут и напишу)

Ответить

Читайте также

Решите задачу

Решите задачу с помощью рассуждения (рассуждения присылать тоже)
Задача: В одном доме живут 3 товарища: Вася, Боря и Дима.
Один из них играет в футбол, другой пишет стихи, а третий лучше всех играет в шахматы.
Известно : 1-ВАсин друг с огорчением сказал "Вчера я не сумел реализировать пинальти" 2-товарищ поэта сказал" Дима! Написал бы и ты что нибудь и для нашей футбольной команды"
Назовите имена футболиста, шахматиста, поэта (с рассуждением)

Ребята,нужно в паскале решить задачи на массив.

1) в массиве 50 элементов. Определить количество чисел больше,равны и меньше нуля.
2) в массиве 20 элементов. Опеределить количество чисел,у которых:
Цифра десятков кратна 2(или просто само число кратно 2) и число больше нуля.
Решение по типу этой задачи. Числа вводятся по запуску программы.

Помогите, с помощью паскаля надо сделать следующее:

Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Так же:
Составить программу, решающую следующую задачу: дан номер некоторого года (целое положительное число). Определить соотв-щий ему номер столетия, учитывая, что, к примеру, началом 20го столетия был 1901 год. Сам то я знаю как решать, но не смогу записать это в паскаль!

Решить задачи с помощью Паскаля:

1. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
2. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую- по убыванию. Здесь решать лучше методом выбора.

PASCAL. нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если рОЧЕНЬ нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если решиш - проси

что угодно, помогу)Вот задача - Под конец учебного года ученики 11 класса решали понять у кого же из них будет самый высокий средний балл ? Известно , что - в классе учится 14 учеников, - Сумма всех средних баллов аттестата = 100.Известно также , что первый ученик имел средний балл, который составляет 1/ 12 суммы всех средних баллов. Второй ученик - на 0,15 % больше, чем первый ученик , но на 1,75 % меньше , чем третий ученик . Средние баллы аттестатов двух сестер были равными среднему арефметичному оценок вышеупомянутых учеников , разделенном на 1.5 . Четвертый ученика на конец года имел такой же балл , как и первый ученик , но на 5% меньше , а остальные ученики - имели равные баллы .Какой средний балл на конец года получил каждЫй?



Вы находитесь на странице вопроса "С помощь Паскаля решить задачи:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.