Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Решить задачи с помощью Паскаля:

5-9 класс

1. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
2. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую- по убыванию. Здесь решать лучше методом выбора.

полька12345 11 сент. 2013 г., 19:50:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Poltorakalina
11 сент. 2013 г., 21:26:27 (10 лет назад)

var i,j:integer;
mas:array [1..10] of integer;
begin
randomize;
for i:= 1 to 10 do 
mas[i]:=random(101);
for j:=1 to 10-1 do
for i:=1 to 10-j do
if mas[i] mod 10 > mas[i+1] mod 10 then
swap(mas[i],mas[i+1]);
for i:=1 to 10 do
writeln(mas[i]);
end.
2)
var a:array[1..10] of Integer; 
i,j:Integer; 
begin 
randomize;
for i:=1 to 10 do
a[ i]:=random(101); 
for i:=1 to 4 do
for j:=i+1 to 5 do
if a[ i] > a[ j] then
swap(a[i],a[j]);
 for i:=5 to 9 do
for j:=i+1 to 10 do
 if a[ i] < a[ j] then

+ 0 -
Agnia81
11 сент. 2013 г., 23:15:14 (10 лет назад)

2) Сортирую не методом выбора, а пузырьковым методом, т.к. мне неизвестна формулировка "метод выбора"
program z1;
var
mas:array[1..10] of Integer;
m,n,temp:integer;
begin
randomize;
for i:=1 to 10 do
begin
mas[i]:=random(100);
end;
for i:=1 to 4 do if mas[i]>mas[i+1] then
begin
temp:=mas[i+1];
mas[i+1]:=mas[i];
mas[i]:=temp;
end;
for i:=6 to 9 do if mas[i]<mas[i+1] then
begin
temp:=mas[i+1];
mas[i+1]:=mas[i];
mas[i]:=temp;
end;
end.

Если нужен еще и вывод на экран - то дописываете перед end. следующее: for i:=1 to 10 do writeln(mas[i])

Насчет первого. Мне непонятна формулировка "отсортировать по последней цифре"

Ответить

Другие вопросы из категории

1. Что такое байт, килобайт, мегабайт и гигабайт?

2. Как байт, килобайт, мегабайт и гигабайт связаны между собой?
3. Сколько битов составляют 1/2 килобайта?
4. Сколько школьных учебников емкостью 350 Кбайт можно разместить на трехдюймовой дискете?

Z kj[chfgbvcfgdddfbcfrdrdfcfdrdfd
Петя и Коля играют в следующую игру: Петя задумывает правило преобразования текстовой информации. Коля может предлагать Пете любые тексты и узнавать

результаты преобразования. Ниже приведены вопросы Коли и ответы Пети в нескольких таких играх. Попробуйте отгадать, какое правило задумал Петя в каждой игре.

Вопросы и ответы Правило преобразования
а ⇒ 1; мама ⇒ 4; весна ⇒ 5
а ⇒ 1; шея ⇒ 2; мама ⇒ 2; огурец ⇒ 3
а ⇒ 0; шея ⇒ 1; мама ⇒ 2; огурец ⇒ 3
а ⇒ а; шея ⇒ яеш; мама ⇒ амам
а ⇒ 1; весна ⇒ 3; дом ⇒ 5; река ⇒ 18

Помогите пожалуйста,ребят. Прошуу..

На паскале
Оплата за электроэнергию производится по следующему правилу: за потребленную мощность до А кВт в месяц оплачивается В рублей за 1 кВт, а за потребленную. энергию сверх установленной нормы оплачивается из расчета С рублей за 1 кВт. Напишите программу, которая вычисляет плату за потребленную электроэнергию.

Читайте также

Решите задачу

Решите задачу с помощью рассуждения (рассуждения присылать тоже)
Задача: В одном доме живут 3 товарища: Вася, Боря и Дима.
Один из них играет в футбол, другой пишет стихи, а третий лучше всех играет в шахматы.
Известно : 1-ВАсин друг с огорчением сказал "Вчера я не сумел реализировать пинальти" 2-товарищ поэта сказал" Дима! Написал бы и ты что нибудь и для нашей футбольной команды"
Назовите имена футболиста, шахматиста, поэта (с рассуждением)

Помогите решить задачи с помощью Паскаля:

1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с сохранением порядка следования.
2. Дана последовательность целых чисел, среди чисел есть одинаковые, создать массив различных чисел последовательности и полученный массив отсортировать по возрастанию.

Помоги решить задачу с помощью "паскаля"

вывести все нечетные числа от -15 до 15.

Помогите пожалуйста решить задачу с помощью паскаля.

1.-Выбрать наибольшее из двух чисел
2.-Найти сумму кубов чисел от 1 до 100
заранее спасибо:З



Вы находитесь на странице вопроса "Решить задачи с помощью Паскаля:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.