Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Для последующих чисел от -15 до 15, все чётные числа возвести в квадрат, нечётные числа заменить на 0. Составить программу.

5-9 класс

НастДвор 05 марта 2017 г., 17:29:51 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
владяныч
05 марта 2017 г., 19:17:16 (7 лет назад)

Var i,ch:integer;

Begin

For i:=-15 to 15 do 

Begin 

Ch:=i;

If ch mod 2 = 0 then begin

Ch:=sqr(ch); writeln(ch, ' '); end

Else begin ch:=0;

Writeln(ch, ' ');end;

 

Readln;

End;

Ответить

Другие вопросы из категории

Эй,человечки,помогите пожалуйста!!!!

Одномерный массив из 8 элементов заполнить случайным образом числами от 10 до 20. Заменить все элементы массива меньше 15 их удвоенными значениями.Вывести на экран монитора первоначальный и преобразованный массивы в столбик (столбики должны быть расположены рядом)

Решить задачу:

Производится одноканальная (моно) звукозапись с частотой дискретизации
48 кГц и глубиной кодирования 16 бит. Запись длится 2 минуты, ее
результаты записываются в файл, сжатие данных не производится. Какое из
приведенных ниже чисел наиболее близко к размеру полученного файла,
выраженному в мегабайтах?

помогите составить программу в паскале

в пионерском лагере N отрядов с различным числом детей/. какой отряд самый малочисленный?

Помогите придумать сказку!

Читайте также

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

задача 1. Дано натуральное число n. Напишите программу выводящую на экран последовательность натуральных чисел от 1 до n. задача 2. Даны

натуральные числа A , B, где B>A. Напишите программу последовательность натуральных чисел от A до B, включающая A и B.

Пожалуйста помогите !!!!!!!!

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку.

2)Написать программу которая бы выводила на экран произведение нечетных чисел от 10 до 20.



Вы находитесь на странице вопроса "Для последующих чисел от -15 до 15, все чётные числа возвести в квадрат, нечётные числа заменить на 0. Составить программу.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.