Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Pascal !! Помогите пожалуйста)

10-11 класс

Надо составить программу в Паскале, где в двумерном массиве вычисляется количество нулей на главной диагонали.
Завтра сдавать надо( В интернете не нашла ничего толкового..

Sonicdanny 08 янв. 2015 г., 12:30:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anna012
08 янв. 2015 г., 13:26:15 (9 лет назад)

Решение задачи на PascalABC (листинг программы по ссылке, сейчас ее попробую передать)

+ 0 -
Veek2001
08 янв. 2015 г., 14:02:16 (9 лет назад)

var
   i,j,s:integer;
   a:array[1..10,1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  for j:=1 to 10 do
    begin
    a[i,j]:=random(-10,10);
    if (a[i,j]=0) and (i=j) then s:=s+1;
    write(a[i,j]:3)
    end;
  writeln
  end;
writeln('Число нулей на главной диагонали: ',s)
end.

Ответить

Другие вопросы из категории

ВОПРОС ЖИЗНИ И СМЕРТИ

Автоматизированная система управления кадрами предприятия хранит личные дела работников в следующем формате: каждое личное дело
содержит 12 страниц, по 36 строк на каждой странице, по 64 символа в каждой строке, каждый символ кодируется одним байтом. Определите количество личных дел, хранимых в автоматизированной системе, если известно, что все данные занимают в памяти компьютера 13,5 мегабайта.

Друзья! Помогите пожалуйста!!! Нужно организовать двумерный массив с количеством элементов 32,заполнить его случайными числами на интервале [10;100]

(концы интервала входят тоже) и вывести на экран монитора в матричном виде! ДЕЛАЕТСЯ ВСЕ НА GWBASIC!!!

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!



Вы находитесь на странице вопроса "Pascal !! Помогите пожалуйста)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.