Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Определить, является ли «счастливым» трамвайный билет с шестизначным номером

10-11 класс

(«счастливым» считается билет, у которого сумма первых трёх чисел совпадает с
суммой трёх последних чисел).

Ananasiki 04 авг. 2013 г., 6:35:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Annakan
04 авг. 2013 г., 8:18:37 (10 лет назад)

Program Task;
Var a: Array of Integer;
    n, b, c, i: Integer;
Begin
    Write('Введите номер билета: №');
    ReadLn(n);
    b := n;
    While b <> 0 Do
    Begin
        b := b Div 10;
        c := c + 1;
    End;
    If (c < 1) Or (c > 6) Then
        WriteLn('Неверный номер билета. Завершение программы.')
    Else
    Begin
        SetLength(a, c);
        b := n;
        For i := c - 1 DownTo 0 Do
        Begin
            a[i] := b Mod 10;
            b := b Div 10;
        End;
        If (a[0] + a[1] + a[2]) = (a[3] + a[4] + a[5]) Then
            WriteLn('Билет "счастливый"!')
        Else
            WriteLn('Не повезло');
    End;
    ReadLn;
End.

Ответить

Другие вопросы из категории

В некотором вузе абитуриенты проходили предварительное тестирование, по результатам которого они могут быть допущены к сдаче вступительных экзаменов в

первом потоке. Тестирование проводится по трём предметам, по каждому предмету абитуриент может набрать от 0 100 баллов. При этом к сдаче экзаменов в первом потоке допускаются абитуриенты, набравшие по результатам тестирования не менее 30 баллов по каждому из трёх предметов, причём сумма баллов должна быть не менее 140. На вход программы подаются сведения о результатах предварительного тестирования. Известно, что общее количество участников тестирования не превосходит 500. В первой строке вводится количество абитуриентов, принимавших участие в тестировании, N. Далее следуют N строк, имеющих следующий формат: <Фамилия> <Имя> <Баллы> Здесь <Фамилия> – строка, состоящая не более чем из 20 символов; <Имя> – строка, состоящая не более чем из 15 символов, <Баллы> – строка, содержащая два целых числа, разделенных пробелом – баллы, полученные на тестировании по каждому из трёх предметов. При этом <Фамилия> и <Имя>, <Имя> и <Баллы> разделены одним пробелом. Пример входной строки: Романов Вельямин 48 39 55 Напишите программу, которая будет выводить на экран фамилии и имена абитуриентов, допущенных к сдаче экзаменов в первом потоке. При этом фамилии должны выводиться в алфавитном порядке.

Помогите решить!!! Пожалуйста

Читайте также

Трамвайный билет имеет шестизначный номер(от 100000 до 999999). Выяснить, является ли билет "счастливым". Билет назовем "счастливым", если первая и

последняя цифра билета являются натуральными ( т.е. делятся на 1 и на само себя ).

Трамвайный билет имеет шестизначный номер(от 100000 до 999999). Выяснить, является ли билет "счастливым". Билет назовем "счастливым", если сумма

первых трёх чисел равна сумме трёх других чисел. Через цикл whili, а также div mod

Из 16-ти чисел, спросите у пользователя ,сколько нужно проанализировать чисел, а затем запросите эти числа и сделайте для каждого вывод, является ли

оно четным или отрицательным.(Паскаль)

Или так: Из 16 -ти чисел,сделайте для каждого вывод,является ли оно четным или отрицательным .(Паскаль)

Помогите пожалуйста,оченьььь срочно надо!Буду благодарна за решение ,спасибо!!!!!!!

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

Помогите пожалуйста с 2 задачами! 1) Простым числом называется натуральное число p>1, натуральными делителями которого которого являются

только два числа: 1 и P. Определить, является ли введенное с клавиатуры число простым.

2) Дано число n. Верно ли, что это число содержит ровно 3 одинаковых цифры?



Вы находитесь на странице вопроса "Определить, является ли «счастливым» трамвайный билет с шестизначным номером", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.