Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан целочисленный массив состоящий из элементов, элементы массива принимают значение от 0 до 100. Составьте программу для вычисления произведения

10-11 класс

элементов массива, которые не четны и делятся на 3.

0002alina78 05 сент. 2013 г., 8:18:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sacha6
05 сент. 2013 г., 10:56:49 (10 лет назад)

const n=10;
var
a:array [1..n] of integer;
i,s:integer;
begin
Randomize;
for i:=1 to n do
begin
  a[i]:=random(100);
  write(a[i],' ');
end;
for i:=1 to n do if (a[i] mod 2 =1) and (a[i] mod 3 =0) then if s=0 then s:=a[i] else s:=s*a[i];
writeln;
writeln(s);
end.

Ответить

Другие вопросы из категории

Доичная система счисления Выполнить действия:

1)1100+1101=

2)101+101=
3)1011*101=
4)111*101=
5)11011-110=
6)10001-1110=
7)1011010:1010=

Помогите пожалуйста!!!! номер 7..
заполнить массив из 10 элементов случайными целыми числами в интервале [0..100] и определить в нем количество четных элементов

паскаль ABC, так, если что, на всякий случай)
пожалуйста помогите, чтоб было еще с объяснением...

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Дан целочисленный массив из 30 элементов, которые могут принимать значения от 0 до 100 – баллы учащихся за итоговый тест по информатике. Напишите програ

мму, которая подсчитывает средний балл класса и выводит на экран номера учеников, набравших баллов больше среднего.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.



Вы находитесь на странице вопроса "Дан целочисленный массив состоящий из элементов, элементы массива принимают значение от 0 до 100. Составьте программу для вычисления произведения", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.