Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1. Дано трехзначное число. Выяснить, является ли оно палиндромом («перевертышем»), то есть таким числом, десятичная запись которого читается одинаково

5-9 класс

слева направо и справа налево

Врубель 29 сент. 2013 г., 22:48:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vyblovaelizaveta
29 сент. 2013 г., 23:51:12 (10 лет назад)

program xxx;

var n, c, d, e, k : integer;

begin

  wtite ('введите 3-х значное число N =');

  readln (n);

  c := n div 100;

  d := (n div 10) mod 10;

  e := n mod 10;

  k:= 100*e + 10*d + c;

  if n = k then write ('палиндром') else write('не палиндром')

end.

Ответить

Другие вопросы из категории

Помогите решить !!!!! На паскале
7 вопрос)

помогите пожалуйста) очень надо...

что такое ПЗУ? и для чего оно служит?

чем хранение на внешних носителях отличается от хранения в оперативной памяти?

Читайте также

Дано трехзначное число. напишите программу, которая определяет:

1) есть ли среди цифр заданного трехзначного числа одинаковые;
Пример входных данных
123 нет
121 да
222 да

2) является ли число '' перевертышем" , т.е. числом , десятичная запись которого читается одинаково слева направо и справа налево.
Пример входных данных
122 нет
121 перевертыш
222 перевертыш

Пожалуйста с примером!!!
Заранее большое спасибо

Помогите пожалуйста. программа Паскаль дано трехзначное число. Напишите программу, которая определяет: является ли число перевертышем, т.е числом,

десятичная запись которого читается одинаково слева направо и справа налево Пример входных данных: 122, 121, 222 Пример выходных данных: нет, перевертыш, перевертыш

С клавиатуры вводится натуральное число n выясните является ли оно квадратом какого то натурального числа если является то выведите это число если нет то

вывести -1 например 4 является квадратом 2 а 17 не является квадратом никакого числа.

Решите пожалуйста,срочно!Дано целое четырехзначное число. Выяснить, является ли оно палиндромом, то есть таким числом,десятичная запись которого

читается одинаково слева направо и справа налево.. имя входного файла Input.txt, имя выходного файла output.txt

Дано трёхзначное число. Напишите программу, которая определяет:

а) есть ли среди цифр заданного целого трёхзначного числа одинаковые;
пример входных данных: 123; 121; 222
пример выходных данных: нет; да; да
б) является ли число "перевёртышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.



Вы находитесь на странице вопроса "1. Дано трехзначное число. Выяснить, является ли оно палиндромом («перевертышем»), то есть таким числом, десятичная запись которого читается одинаково", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.