Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Решите пожалуйста,срочно!Дано целое четырехзначное число. Выяснить, является ли оно палиндромом, то есть таким числом,десятичная запись которого

5-9 класс

читается одинаково слева направо и справа налево.. имя входного файла Input.txt, имя выходного файла output.txt

JonhCooper 06 апр. 2015 г., 4:50:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Oxiksana
06 апр. 2015 г., 7:19:56 (9 лет назад)

#include "stdio.h";

int main(){
 FILE *f;
 f=fopen("INPUT.TXT","r");
 int n,a1,a2,tmp;
 fscanf(f,"%d",&n);
 fclose(f);
 a1=(n%10)*10+((n/10)%10);
 tmp=(n/100);
 a2=(tmp%10)+((tmp/10)%10)*10;
 f=fopen("OUTPUT.TXT","wt");
 if (a1==a2) fprintf(f,"YES");
 else fprintf(f,"NO");
 fclose(f);
 return 0;
};

+ 0 -
Pidarajr
06 апр. 2015 г., 9:23:17 (9 лет назад)

Язык Python

 

 

iFile = open("input.txt", 'r')                             # открываем файл для чтения

oFile = open('output.txt', 'w')                         # открываем файл для записи

 

for line in iFile.readlines():                           # считываем все стройи из входного файла и идем по ним в цыкле

  if line[0]==line[-1] and line[1]==line[-2]:   # если первый символ равен последнему, а второй предпоследнему

    oFile.write('yes\n')                                      # пишем да

  else:

    oFile.write('no\n')                                        # пишем нет

iFile.close()                                                     # закрываем файлы

oFile.close()

Ответить

Другие вопросы из категории

Пожалуйста, помогите! Я накосячила со своей флешкой. Короче, компьютер ее теперь не видит, но пару раз что-то выскакивало, типа: Программа была

остановлена, т. к. один из драйверов сообщил об ошибке (Код 43). Нашла в интернете, что делать... Общие свойства, вызвать Мастера неполадок. ГДЕ ИСКАТЬ ЭТИ ОБЩИЕ СВОЙСТВА? Короче, помогиииите

ПОМОГИТЕ СРОЧНО!

Вводятся значения двух ЦИФР. Напечатать максимальное двузначное число, которое можно сформировать из этих цифр или сообщение, что таких двузначных чисел не существует. (Pascal)

Читайте также

Дан массив целых чисел. Выяснить:

1) является ли s-й элемент массива положительным числом;
2) является ли k-й элемент массива чётным числом;
3) какой элемент массива больше k-й или s-й.
Паскаль для Лазаруса.

Помогите пожалуйста. программа Паскаль дано трехзначное число. Напишите программу, которая определяет: является ли число перевертышем, т.е числом,

десятичная запись которого читается одинаково слева направо и справа налево Пример входных данных: 122, 121, 222 Пример выходных данных: нет, перевертыш, перевертыш

Тема:Integer

Задача: Дано одно целое число, проверить, является ли оно простым. (делится на 1 и на само себя).
Помогите пожалуйста)

ЛЮДИ ПОМОГИТЕ!!!

Дано натуральное число. Выяснить является ли оно простым. Паскаль
Если можно с пояснениями пожалуйста



Вы находитесь на странице вопроса "Решите пожалуйста,срочно!Дано целое четырехзначное число. Выяснить, является ли оно палиндромом, то есть таким числом,десятичная запись которого", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.