Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан одномерный массив из 1000 элементов, состоящий из случайных целых чисел в диапазоне от -5 до 8. Найти сумму элементов участка массива, начиная с

10-11 класс

первого положительного и кончая вторым положительным элементом.

Lololo2212 02 июля 2014 г., 2:09:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
DJFox
02 июля 2014 г., 5:04:49 (9 лет назад)

Как то так:
var  a: array[1..1000] of integer; 
b: array [1..2] of integer; 
i, j, sum: integer;
begin 
 for i := 1 to 1000 do    
a[i] := random(13) - 5; 
 j := 1; 
 for i := 1 to 1000 do   begin   
if j = 3 then break;   
if a[i] > 0 then begin b[j] := i;inc(j); end; 
end; 
 for i := b[1] to b[2] do    sum := sum + a[i]; 
writeln(sum);
end.

Ответить

Другие вопросы из категории

Люди помогайте!!!))) Паскаль!!!

1)Составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями.

2)Составьте программу заполнения массива из десяти чисел следующими значениями
а) 2 4 6 8 10 (+ 2)
б)3 6 9 12 15 (+3)

8^x кбайт =16 гбайт помогите решить

Читайте также

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

Напишите пожалуйста в Паскаль.

Массив из 15 элементов заполнить случайными четными числами в интервале от -25 до 70. Вывести полученный массив на экран в строчку.Найти сумму наибольшего и наименьшего элементов массива. (Использовать пузырьковую сортировку).

Написать в Паскаль

Массив из 15 элементов заполнить случайными четными числами в интервале от -25 до 70. Вывести полученный массив на экран в строчку.Найти сумму наибольшего и наименьшего элементов массива. (Использовать пузырьковую сортировку).



Вы находитесь на странице вопроса "Дан одномерный массив из 1000 элементов, состоящий из случайных целых чисел в диапазоне от -5 до 8. Найти сумму элементов участка массива, начиная с", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.