Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты.если разностьпервых двух чисел превышает четвертое,то

5-9 класс

выведите все четыре числа без изменения. Если сумма всех чисел не больше 80, то выведите только два первых числа. Если выполняется одновременно два перечисленных выше условия, то выведите только два последних числа.Иначе, выведите все четыре числа,увеличев их на 5

Ксюша15032003 26 авг. 2014 г., 14:45:19 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ellina16
26 авг. 2014 г., 16:49:17 (9 лет назад)

Одна тонкость - разность первых  2-ух чисел это из первого вычитаем второе или из второго первое? 

 

Program Chisla;

Uses Crt;

var a,b,c,d,sum:real;

begin

 

     clrscr;

     write('Введите первое число: ');

     readln(a);

      write('Введите второе число: ');

      readln(b);     

      write('Введите третье число: ');

      readln(c); 

      write('Введите четвёртое число: ');

      readln(d);

 

 

       sum:=a+b+c+d;

       if ((a-b)>d) and (sum<=80) then writeln(c,d)

             else

 

                   if (a-b)>d  then writeln(a,b,c,d)

            else

                 if  (sum<=80)  then writeln(a,b)

 

                    else    writeln(a+5,b+5,c+5,d+5);

     readkey;

end.

 

 

 

 

 

 

         

 

  

Ответить

Другие вопросы из категории

параграф 4 вопрос 4 писмено
Надо двоичный код перевести в десятичный

101,101-5,5
1000,1000-
1001,1000-
1011,110-
1100,110-
1100,111-
1011,111-
1011,10-
1001,10-
1001,11
1010,11
1010,100
111,100
111,10

как превратить пиратку в

лицензию

Читайте также

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

· Если второе и четвертое числа отрицательны, то выведите их произведение.

· Если первое и третье числа больше 10, то выведите все четыре числа, увеличив их в десять раз

· Если выполняются одновременно два перечисленных выше условия, то выведите эти четыре числа без изменения.

· Иначе, выведите все четыре числа, уменьшив их в десять раз.

Составьте соответствующие отладочные примеры и проверьте работу каждой программы.

Кто знает как решать?

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран
соответствующие результаты.

·

Составить программу в паскале: Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты.:

· Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел.

· Если произведение этих чисел больше их суммы, то выведите эти сумму и произведение.

· Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму

· Иначе, выведите удвоенные значения этих чисел

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .



Вы находитесь на странице вопроса "Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты.если разностьпервых двух чисел превышает четвертое,то", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.