Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Задача №3 (Владения рыцаря)

5-9 класс

Английская система
мер1 миля 1760 ярдов
1 ярд 3 фута
1 фут 12 дюймов
1 дюйм 12 линий
Рыцарь сэр Джон купил новый замок и послал двух своих слуг измерить периметрсвоего нового владения. Один измерял длину другой ширину. Выяснилось, что оградаявляется точным прямоугольником. Требуется написать программу, которая подсчитаетпериметр.Формат входных данных:ввод производить в виде двух строк. в каждой из строк записан результат измеренийслуги. При этом каждая величина записана в формате:M Y F D L, где M (0 <= M <= 10000)- мили, Y (0 <= Y <= 1760)- ярды, F - (0 <= F <= 3)футы, D - (0 <= D <= 12) дюймы, L - (0 <= L <= 12) линии. (Отсутствующее числозаменяеться на 0)
Ври выводе использовать сокращенные меры - миля=мл. ярды = ярд. фут=фт.дюймы=фт. линии=лн.
Примеры вводных и выходных данных:
ВВОД:1 3 2 11 011 0 0 0 0
ВЫВОД: 24 мл. 7 ярд. 2 фт. 10дм. 0лн

Shkolnik1390 01 марта 2014 г., 13:14:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bepa486
01 марта 2014 г., 14:38:46 (10 лет назад)

Паскаль АВС:

Program Greenpigs;
uses crt;
var
  Lmile, Wmile, Lyard, Wyard, Lfoot, Wfoot, Linch, Winch, Lline, Wline:integer;
begin
  writeln('Введите длину:');
  writeln('Мили, ярды, футы, дюймы, линии:');
  repeat
    readln (Lmile, Lyard, Lfoot, Linch, Lline);
  until ((Lmile>=0)and(Lmile<=10000)and(Lyard>=0)and(Lyard<1760)and(Lfoot>=0)and(Lfoot<3)and(Linch>=0)and(Linch<12)and(Lline>=0)and(Lline<12));
  writeln('Введите ширину:');
  writeln('Мили, ярды, футы, дюймы, линии:');
repeat
  readln (Wmile, Wyard, Wfoot, Winch, Wline);
until ((Wmile>=0)and(Wmile<=10000)and(Wyard>=0)and(Wyard<1760)and(Wfoot>=0)and(Wfoot<3)and(Winch>=0)and(Winch<12)and(Wline>=0)and(Wline<12));
  Lmile:=2*(Lmile+Wmile);
  Lyard:=2*(Lyard+Wyard);
  Lfoot:=2*(Lfoot+Wfoot);
  Linch:=2*(Linch+Winch);
  Lline:=2*(Lline+Wline);
  while (Lline>=12) do
    begin
       Lline:=Lline-12;
       Linch:=Linch+1;
    end;
  while (Linch>=12) do
    begin
       Linch:=Linch-12;
       Lfoot:=Lfoot+1;
    end;
  while (Lfoot>=3) do
    begin
       Lfoot:=Lfoot-3;
       Lyard:=Lyard+1;
    end;
  while (Lyard>=1760) do
    begin
       Lyard:=Lyard-1760;
       Lmile:=Lmile+1
    end; 
writeln('Периметр равен ',Lmile,' мл. ',Lyard,' ярд. ',Lfoot,' фт. ',Linch,' дюйм. ',Lline,' лн. ');
end.

Ответить

Другие вопросы из категории

Вы посетили магазин и купили 10 видов товара.В таблицу T[1:10] вы записали количество купленного товара каждого вида.В таблицу C[1:10] записали цены

единиц каждого вида товара соответственно.Составьте алгоритм вычисления общей стоимости всех покупок.
помогите семестровая решается очень нужно)))

Три друга: Алеша, Боря и Витя учатся

в одном классе. Один из них ездит домой из школы на троллейбусе, другой – на
трамвае, третий – на автобусе. Однажды после уроков Алеша пошел проводить
своего друга до остановки тролейбуса. Когда мимо них проходил автобус, третий
друг крикнул из окна: «Боря, ты забыл в школе тетрадку!». Кто на чем ездит
домой?

Помогите пожалуйста и объясните почему:


1)Для какого из указанных значений числа X ложно выражение

Читайте также

Составьте алгоритм решения следующей задачи. Как переправиться на другой берег реки трем рыцарям и оруженосцам, если имеется двухместная лодка и известно,

что оруженосец не плывет и не остается на берегу с чужими рыцарями без товарищей?
b)У исполнителя Вычислитель две команды:
1. x+n
Это означает, что если точка имеет координаты (x,y), то новая координата по x становится равной x+n. Координата по y при этом становится равной y+2n-10.
2. y+m
Это означает, что если точка имеет координаты (x,y), то новая координата по y становится равной y+m. Координата по x при этом становится равной x+40-m. Команды разделяются запятыми. Например, программа x+1, y+1 переводит точку с координатами (100,100) в точку с координатами (140,93). Известно, что программа x+25, y+32 перевела некоторую точку в точку (67, 76). Найти координаты начальной точки.

Решите задачу

Решите задачу с помощью рассуждения (рассуждения присылать тоже)
Задача: В одном доме живут 3 товарища: Вася, Боря и Дима.
Один из них играет в футбол, другой пишет стихи, а третий лучше всех играет в шахматы.
Известно : 1-ВАсин друг с огорчением сказал "Вчера я не сумел реализировать пинальти" 2-товарищ поэта сказал" Дима! Написал бы и ты что нибудь и для нашей футбольной команды"
Назовите имена футболиста, шахматиста, поэта (с рассуждением)

Помогите решить задачу!!!!

Очень нужно)
Задача 11!!!!!))))

Решите задачу 9 класс. Срочно! Много баллов!

Достаточно ли видеопамяти объемом 256 кбайт для работы монитора в режиме 640х480 и палитрой из 16 цветов.
Оформить как задачу (Дано, решение, все формулы и т.п)

Задача по икт в виде таблицы истины ( дизъюнкция, коньюкция, инверсия )

Задача:
не (a или b) и (c или b)



Вы находитесь на странице вопроса "Задача №3 (Владения рыцаря)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.