Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите, пожалуйста!!!! Паскаль

5-9 класс

дано четырехзначное число, заменить нулем максимальную цифру

иман15 05 янв. 2014 г., 20:34:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dily1999465646
05 янв. 2014 г., 21:21:26 (10 лет назад)

uses crt;
var a:integer;
b:array[1..4] of integer;
max,i,k,t:integer;
begin
readln(a);
k:=1;
repeat
for i:=k to k do
b[i]:=a mod 10;
a:=a div 10;
inc(k);
until a=0;
max:=0;
for i:=1 to 4 do
if b[i]>max then begin max:=b[i]; t:=i; end;
b[t]:=0;
for i:=4 downto 1 do
write(b[i]);
end.

+ 0 -
VeronikAFeeD
05 янв. 2014 г., 23:19:01 (10 лет назад)

вводила программу, он ошибку выдаетvar s,d,e,b:real; a:integer;

begin
write ('vv 4-h znachnoe chislo');
read (a);
b:=a/1000;
s:=a/100 mod 10;
d:=a/10 mod 10;
e:= a mod 10;write (a,b,c,d,e);
end.

+ 0 -
Olgam86
05 янв. 2014 г., 23:55:57 (10 лет назад)

что не так?

Ответить

Другие вопросы из категории

теплоход рассчитан на 750 пассажиров и 25 членов команды.каждая спасательная шлюпка может вместить 50 человек.каое наименьшее число шлюпок должно быть

на теплоходе,чтобы в случае необходимости в них можно было разместить всех пассажиров и всех членов комнанды? ПОМОГИТЕ ПОЖАЛУЙСТА!! ОЧЕНЬ НУЖНО!!(((

Очень срочно помогите!!! Надо решить в паскале!

находится ли число a между числами b и c
Используя if then else

Читайте также

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!



Вы находитесь на странице вопроса "Помогите, пожалуйста!!!! Паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.