Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите описать алгоритм!!!

10-11 класс

uses crt;


var s, sn, sg: string;


i: integer;


begin


write('s=');


readln(s); sn:='';


for i:=1 to length(s) do

Paulamanka 24 апр. 2013 г., 21:57:57 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MrHolmes5
24 апр. 2013 г., 23:17:38 (11 лет назад)

А что тут особо описывать? Считывается строка, потом в ней делается корявая попытка заменить найденную точку троеточием. Поскольку при такой замене появляются две добавочные точки, под замену попадает вторая из вставленных точек и заменяется еще на две... строка постоянно растет на две точки, они множатся... а цикл идет до первоначальной длины строки.
Результат - после первой точки в строку вставляются точки в количестве, равном количеству символов, считая от позиции этой точки до конца строки в её первоначальном виде. Остальные символы из первичного вида строки останутся неизменными, следуя за полученным набором точек.

+ 0 -
DivaG
25 апр. 2013 г., 0:16:27 (11 лет назад)

uses crt;
var s, sn: string;
  i: integer;
begin
  write('s=');
  readln(s);

  sn := '';
  for i := 1 to length(s) do   
    if s[i] = '.' then
      sn := sn + '...'
    else sn := sn + s[i];
   
  write('s=', sn);
  readkey;
end.

Вводим строку. Пробегаем по всей ее длине и каждый символ по очереди записываем в новуйу строку, если же встречаем точку, то записываем вместо нее троеточие
Короче - заменяем все точки строки на троеточия


Ответить

Другие вопросы из категории

Для кодирования

букв Е,П, Н, Ч, Ь используются двоичные
коды чисел 0, 1, 2, 3 и 4 соответственно (с
сохранением одного незначащего нуля
в случае одноразрядного представления).
Если таким способом закодировать
последовательность символов ПЕЧЕНЬЕ
и записать результат в восьмеричном
коде, то получится:


1) 1030240 2) 12017 3) 2141351 4) 23120

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.

Читайте также

Помогите составить алгоритм!

Составьте алгоритм(в паскале\на алгоритмическом языке), в котором вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних месяцев, осенних месяцев.

Помогите составить алгоритм:Помогите составить алгоритм: Требуется рассчитать необходимое кол-во рулонов обоев для оклейки комнаты.Заданы параметры

комнаты а,b,h.Заданы параметры рулонов обоев длина l,ширина-d,считаем что S окон и дверей составляет 15 % от площади стен.



Вы находитесь на странице вопроса "Помогите описать алгоритм!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.